Jump to content


Photo

Windows Vista Compatibility problems


  • Please log in to reply
7 replies to this topic

#1 jmort

jmort

    Member

  • Members
  • Pip
  • 6 posts

Posted 02 April 2007 - 09:16 AM

Hi,

First the positive- I love Spell Catcher with a passion that makes my other applications jealous. I can't live without it. I have it at work and at home. If I am on a computer without it, it's like the computer is no good to me. Spell Catcher is the wind beneath my wings.

That said, I just got a new computer at home with Windows Vista. I did not want to get Vista but I couldn't really avoid it.

Spell Catcher Plus 3 didn't work. When I boot up the computer, I had to launch Spell Catcher manually because Vista is a mite touchy about applications in startup (it blocks them). Still, with Spell Catcher running, I went into an application and typed out a Word for which I had a custom shortcut. I see the green box appear, but then I can't apply the shorthand. Moreover, after that initial appearance, no other shorthand boxes were displayed.

I have windows Vista Home Premium shipping edition which came with my new computer.

I faithfully came to this site, hunted for and found the Vista patch (scp_2134.exe), and installed it. However, my Spell Catcher still does not work. When I try to launch it I get an error message and it doesn't launch. (I did this last night- I don't remember the message but I can get back to you with it again later if it'll help).

Is there a new upgrade you are working on or should the existing patch work? Thanks for your help and for this terrific product.

#2 jmort

jmort

    Member

  • Members
  • Pip
  • 6 posts

Posted 02 April 2007 - 09:58 PM

By the way, the error msg is this...

The file "SCInstaller.exe" isn't found in Spell Catcher's folder.

#3 John Tytler

John Tytler

    Member

  • Admin
  • PipPipPip
  • 191 posts

Posted 05 April 2007 - 11:52 AM

Hi,

Thanks for your question.

Spell Catcher does work with Vista; however, there seem to be ways to launch the program yet have none of its word replacement operations actually do anything. This has to do with Vista and the new security arrangements that are incorporated into MSís latest OS.

From what I have observed, you must make sure that the "Run as Administrator" checkbox in the Properties -> Compatibility Tab IS NOT CHECKED OFF. If it is, it seems that Spell Catcher doesn't work properly.

Furthermore, their may be an issue with Spell Catcher being launched when Vista boots, so this option should not be used within Vista. Regardless of your configuration, it seems that Vista needs an admin password to launch Spell Catcher properly. I'm sure you are providing this!

We need to figure out what other Vista features have to be checked or unchecked to get Spell Catcher working on your machine.

Can you find the Compatibility Tab in the Properties dialog? There is one for Spell Catcher's shortcut on the desktop and another for the actual application. Make sure NONE of the checkboxes are ticked in either Property dialog...

Let me know your findings...

John Tytler
Author - Spell Catcher Plus
Rainmaker Research, Inc.

#4 jmort

jmort

    Member

  • Members
  • Pip
  • 6 posts

Posted 06 April 2007 - 12:34 PM

From what I have observed, you must make sure that the "Run as Administrator" checkbox in the Properties -> Compatibility Tab IS NOT CHECKED OFF. If it is, it seems that Spell Catcher doesn't work properly.

Furthermore, their may be an issue with Spell Catcher being launched when Vista boots, so this option should not be used within Vista. Regardless of your configuration, it seems that Vista needs an admin password to launch Spell Catcher properly. I'm sure you are providing this!

We need to figure out what other Vista features have to be checked or unchecked to get Spell Catcher working on your machine.

Can you find the Compatibility Tab in the Properties dialog? There is one for Spell Catcher's shortcut on the desktop and another for the actual application. Make sure NONE of the checkboxes are ticked in either Property dialog...

Let me know your findings...


Hi John,

Thanks for getting back to me.

The shortcut on the dsktop was not running as an administrator so I changed that setting. The actual program .exe file did have that turned on, though. In either case, when I run it, I still get the following error

The file "SCInstaller.exe" isn't found in Spell Catcher's folder

Any help would be great. Thanks.

#5 jmort

jmort

    Member

  • Members
  • Pip
  • 6 posts

Posted 10 April 2007 - 10:06 PM

I got the update you sent but it still didn't do the trick.

I am running it in Administrator mode - when i right-click on the icon and select Properties, on the Compatibility tab under Priviledge level, the Run this program as an administrator is checked. It also is when I look at the .exe file in the Program files folder.

You mentioned that the problem might be something to do with admin priviledges. Is there anything else I can do to verfiy this?

#6 jmort

jmort

    Member

  • Members
  • Pip
  • 6 posts

Posted 20 April 2007 - 08:35 AM

Thanks for the phone call, John. I appreciate you trying to work with me on this.

I don't know why my copy of Vista seems to be different than the ones you tested. if I am able to discover why Spell Catcher isn't working on my computer, I'll be sure to let you know.

For now, I still have it on my old system.

Thanks.

#7 John Tytler

John Tytler

    Member

  • Admin
  • PipPipPip
  • 191 posts

Posted 04 May 2007 - 01:08 PM

For those using Vista or IE7 with Spell Catcher, be sure to download the latest build #2174. The word replacement algorithm continues to be adjusted to suit both Vista and IE7ís particular needs.

John Tytler
Author - Spell Catcher for Windows
Rainmaker Research, Inc.

#8 jmort

jmort

    Member

  • Members
  • Pip
  • 6 posts

Posted 11 July 2007 - 09:07 AM

I had another go at Spell Catcher today - trying to get it to work with Windows Vista... I made sure that the "Run in Administrator Mode" was turned off, which it was. But then I realized that I have multiple accounts on this machone, so I went to the properties for all users and turned off the administrator settings and guess what? It worked!

So for those that are having trouble on Vista, make sure that you turn off "Run as Administrator" for all users, not just yourself. I am so happy now that I have my Spell Catcher back after all this time.