Jump to content


Photo

SC Input Menu choice will not stay selected


  • Please log in to reply
12 replies to this topic

#1 Rick

Rick

    Member

  • Members
  • PipPip
  • 16 posts
  • Gender:Male
  • Location:Gainesville, FL

Posted 27 October 2008 - 11:47 PM

OK, I just upgraded to SC X 10.3.1. No matter what I try, the input method keeps changing back to the American flag. It doesn't happen right away. I can switch to the Spell Catcher Check Mark and it will stay for 1, 2, 5, 10 minutes (maybe more, it appears random) and then switch to the flag without warning or any other notice.

I have tried the steps in the Leopard FAQ ( this FAQ link ). The Input Menu choice was not reliable under SC X 10.3 either, but it wasn't anywhere near this bad.

I'm running a MBP 17 (MacBookPro2.1 in System Profiler), 3 GB RAM, Mac OS X 10.5.5 and SC X 10.3.1. I've been using SC on Mac and Windows for a long time (since Batteries Included/Thunder days) and the Mac since late 1984, so I've good handle on how they normally work together. I just can't figure out what's causing this odd behavior. FYI, I also had the CFMessagePort problem and this makes me wonder if that message isn't as "innocent" as being claimed.

Also, I miss DiskTools - just had to say that.

Rick

#2 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 28 October 2008 - 02:12 AM

OK, I just upgraded to SC X 10.3.1. No matter what I try, the input method keeps changing back to the American flag. It doesn't happen right away. I can switch to the Spell Catcher Check Mark and it will stay for 1, 2, 5, 10 minutes (maybe more, it appears random) and then switch to the flag without warning or any other notice.

I have tried the steps in the Leopard FAQ ( this FAQ link ). The Input Menu choice was not reliable under SC X 10.3 either, but it wasn't anywhere near this bad.

I'm running a MBP 17 (MacBookPro2.1 in System Profiler), 3 GB RAM, Mac OS X 10.5.5 and SC X 10.3.1. I've been using SC on Mac and Windows for a long time (since Batteries Included/Thunder days) and the Mac since late 1984, so I've good handle on how they normally work together. I just can't figure out what's causing this odd behavior. FYI, I also had the CFMessagePort problem and this makes me wonder if that message isn't as "innocent" as being claimed.

Also, I miss DiskTools - just had to say that.

Rick


Might be that the preference file containing your Input menu configuration is damaged.

Try this:

Navigate to your HOME ~/Library/Preferences/ByHost folder.
Trash the file named like "com.apple.HIToolbox.......plist" (don't Empty the Trash).
Restart immediately.
Empty the Trash when you're logged in again.
Open International System Preferences, Input Menu tab, configure your Input menu manually.
Launch the Spell Catcher app directly - i.e. not indirectly by choosing Spell Catcher from the Input menu.
Choose Spell Catcher > Preferences, view the Interactive pane, activate Spell Catcher by clicking the "Activate Now" button near the bottom of the window.

This type of problem is always due to the Mac OS itself - a preference or cache file that's either damaged or out-of-sync with another dependent file. Where input method components are involved, there are at least two cache files and the above ByHost/com.apple.HIToolbox preference file that must be totally in-sync with reality.

And the CFMessagePort error is as innocent as claimed. Really. Truly.

#3 Rick

Rick

    Member

  • Members
  • PipPip
  • 16 posts
  • Gender:Male
  • Location:Gainesville, FL

Posted 28 October 2008 - 10:38 AM

OK, I just upgraded to SC X 10.3.1. No matter what I try, the input method keeps changing back to the American flag. It doesn't happen right away. I can switch to the Spell Catcher Check Mark and it will stay for 1, 2, 5, 10 minutes (maybe more, it appears random) and then switch to the flag without warning or any other notice.

I have tried the steps in the Leopard FAQ ( this FAQ link ). The Input Menu choice was not reliable under SC X 10.3 either, but it wasn't anywhere near this bad.

I'm running a MBP 17 (MacBookPro2.1 in System Profiler), 3 GB RAM, Mac OS X 10.5.5 and SC X 10.3.1. I've been using SC on Mac and Windows for a long time (since Batteries Included/Thunder days) and the Mac since late 1984, so I've good handle on how they normally work together. I just can't figure out what's causing this odd behavior. FYI, I also had the CFMessagePort problem and this makes me wonder if that message isn't as "innocent" as being claimed.

Also, I miss DiskTools - just had to say that.

Rick


Might be that the preference file containing your Input menu configuration is damaged.

Try this:

Navigate to your HOME ~/Library/Preferences/ByHost folder.
Trash the file named like "com.apple.HIToolbox.......plist" (don't Empty the Trash).
Restart immediately.
Empty the Trash when you're logged in again.
Open International System Preferences, Input Menu tab, configure your Input menu manually.
Launch the Spell Catcher app directly - i.e. not indirectly by choosing Spell Catcher from the Input menu.
Choose Spell Catcher > Preferences, view the Interactive pane, activate Spell Catcher by clicking the "Activate Now" button near the bottom of the window.

This type of problem is always due to the Mac OS itself - a preference or cache file that's either damaged or out-of-sync with another dependent file. Where input method components are involved, there are at least two cache files and the above ByHost/com.apple.HIToolbox preference file that must be totally in-sync with reality.

And the CFMessagePort error is as innocent as claimed. Really. Truly.



OK, I tried those steps once before but Spell Catcher was in the Login Items and launched during the next startup and I used the Input menu. This time I removed it from Login Items, restarted, emptied the trash, did the startup from the app itself, and used the button on the Interactive pane to Activate it. It activated and then immediately deactivated, but I happened to notice that the help text near the Activate button said that if it did that, to click the Activate button again. This time it Activated and stayed active.

So far, it's been about an hour, maybe 90 minutes and SC is still active, so things look promising. It generally wouldn't make it 5 minutes before. Before this process, I had two items in the ByHost folder that matched the pattern "com.apple.HIToolbox.......plist" but now I only have one. Just an FYI.

And the same on CFMessagePort. I believe you. As a user, you just never know what info will help someone doing tech support have an "ah-ha!" moment. So I figured I'd mention it in case it helped you identify a pattern.

Thanks.

Rick

#4 Rick

Rick

    Member

  • Members
  • PipPip
  • 16 posts
  • Gender:Male
  • Location:Gainesville, FL

Posted 28 October 2008 - 09:42 PM

OK, it's much better now, but still switches to the flag silently, unexpectedly, and without discernible pattern or instigation, which deactivates SC X. What might cause this?

Rick

#5 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 29 October 2008 - 01:19 AM

OK, it's much better now, but still switches to the flag silently, unexpectedly, and without discernible pattern or instigation, which deactivates SC X. What might cause this?

Rick


A couple of possibilities:

1. The Mac OS will automatically select your keyboard (flag icon) whenever you are in a secure input area - such as when entering a password in an authorization dialog or the like. Generally, it will restore the previously-active input source once you leave the secure entry field - if it doesn't, then it's a Mac OS bug.
2. You have a keyboard shortcut set (System Preferences, Keyboard & Mouse, Keyboard Shortcuts tab, Input menu items) to switch the active input source, and you're typing that shortcut inadvertently.
3. Bug(s) in Mac OS X.

Keep a close eye on this, see if you can determine *exactly* when it happens.

#6 Rick

Rick

    Member

  • Members
  • PipPip
  • 16 posts
  • Gender:Male
  • Location:Gainesville, FL

Posted 29 October 2008 - 08:17 AM

OK, it's much better now, but still switches to the flag silently, unexpectedly, and without discernible pattern or instigation, which deactivates SC X. What might cause this?

Rick


A couple of possibilities:

1. The Mac OS will automatically select your keyboard (flag icon) whenever you are in a secure input area - such as when entering a password in an authorization dialog or the like. Generally, it will restore the previously-active input source once you leave the secure entry field - if it doesn't, then it's a Mac OS bug.
2. You have a keyboard shortcut set (System Preferences, Keyboard & Mouse, Keyboard Shortcuts tab, Input menu items) to switch the active input source, and you're typing that shortcut inadvertently.
3. Bug(s) in Mac OS X.

Keep a close eye on this, see if you can determine *exactly* when it happens.


#1. Hmm. OK, I'll keep watching and try to see when it switches back. I'm in secure input areas a lot on websites (logins/passwords, etc - & use 1Password).
#2. Don't think I have a keyboard shortcut for this unless one comes predefined in the OS. Don't know why I'd want one. I have pretty simple needs in this area. I only type english and use SC. I will try to ensure a key hasn't been defined.
#3. Bugs in Mac OS X! Don't let Apple hear you say that! That's like saying the iPhone needs copy and paste!

Thanks.

Rick

#7 Rick

Rick

    Member

  • Members
  • PipPip
  • 16 posts
  • Gender:Male
  • Location:Gainesville, FL

Posted 30 October 2008 - 09:42 PM

OK, I have found at least one thing that shuts off Spell Catcher. If I switch to Microsoft Word, Excel, PowerPoint, or Entourage 11.5.x, Spell Catcher shuts off. There is a custom application setting for Entourage, Excel, and PowerPoint but not for Word. I remove the custom application setting for Entourage, but that didn't seem to change anything. In each of these applications, I can't even manually select Spell Catcher from the menu while I'm in those applications. But I used SC in them all the time in SC 10.2.x.

What can I do?

Rick

#8 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 30 October 2008 - 10:02 PM

OK, I have found at least one thing that shuts off Spell Catcher. If I switch to Microsoft Word, Excel, PowerPoint, or Entourage 11.5.x, Spell Catcher shuts off. There is a custom application setting for Entourage, Excel, and PowerPoint but not for Word. I remove the custom application setting for Entourage, but that didn't seem to change anything. In each of these applications, I can't even manually select Spell Catcher from the menu while I'm in those applications. But I used SC in them all the time in SC 10.2.x.

What can I do?

Rick


OK, you're running into a bug in Mac OS X related to properly enabling input sources in the Input menu for old-style Carbon applications like the ones you mention.

This is a mysterious one - at least I haven't figured out a 100% effective solution. Once you get this working, though, it usually sticks.

It takes some amount of "fiddling." This is what I usually try, in easiest-and-fastest to easy-but-requires-restarting order (it's been months since I've seen it happen, though). Seems that any one of these steps can be the remedy, but no single one seems to work all the time:

1. Quit and re-launch the app you're having trouble with.
2. Open International System Preferences, Input Menu tab, turn Spell Catcher off then back on again.
3. Quit the "problem" app, Quit the Spell Catcher app, then launch the Spell Catcher app directly (not indirectly by choosing it from the Input menu). Open the "problem" app. See if you can select Spell Catcher from the Input menu.
4. Try using the "Activate Now" button in Spell Catcher Preferences, Interactive tab. If the button says "Deactivate", click it, then when it reads "Activate", click it again.

Try restarting if you have no luck with the above. Hang in there, it will work, and will stick, but it does seem to require a certain amount of fiddling, like I said.

#9 Rick

Rick

    Member

  • Members
  • PipPip
  • 16 posts
  • Gender:Male
  • Location:Gainesville, FL

Posted 30 October 2008 - 11:23 PM

OK, I have found at least one thing that shuts off Spell Catcher. If I switch to Microsoft Word, Excel, PowerPoint, or Entourage 11.5.x, Spell Catcher shuts off. There is a custom application setting for Entourage, Excel, and PowerPoint but not for Word. I remove the custom application setting for Entourage, but that didn't seem to change anything. In each of these applications, I can't even manually select Spell Catcher from the menu while I'm in those applications. But I used SC in them all the time in SC 10.2.x.

What can I do?

Rick


OK, you're running into a bug in Mac OS X related to properly enabling input sources in the Input menu for old-style Carbon applications like the ones you mention.

This is a mysterious one - at least I haven't figured out a 100% effective solution. Once you get this working, though, it usually sticks.

It takes some amount of "fiddling." This is what I usually try, in easiest-and-fastest to easy-but-requires-restarting order (it's been months since I've seen it happen, though). Seems that any one of these steps can be the remedy, but no single one seems to work all the time:

1. Quit and re-launch the app you're having trouble with.
2. Open International System Preferences, Input Menu tab, turn Spell Catcher off then back on again.
3. Quit the "problem" app, Quit the Spell Catcher app, then launch the Spell Catcher app directly (not indirectly by choosing it from the Input menu). Open the "problem" app. See if you can select Spell Catcher from the Input menu.
4. Try using the "Activate Now" button in Spell Catcher Preferences, Interactive tab. If the button says "Deactivate", click it, then when it reads "Activate", click it again.

Try restarting if you have no luck with the above. Hang in there, it will work, and will stick, but it does seem to require a certain amount of fiddling, like I said.


Ah, I'm always the one who gets these odd problems. I've tried these steps and several variations with no success so far. When is the right time in the steps for a restart? I'd like to try combinations that are more likely to get the Input Sources enabled again.

#10 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 31 October 2008 - 12:10 AM

Ah, I'm always the one who gets these odd problems. I've tried these steps and several variations with no success so far. When is the right time in the steps for a restart? I'd like to try combinations that are more likely to get the Input Sources enabled again.


If I knew exactly what worked, I'd certainly tell you. The thing is, whenever it would happen to me during development, I just fiddled around for a bit, trying the various things I described. Inevitably one of them would kick things into gear, and the problem usually went away for a while.

All I could figure out was that:
- it had something to do with installing or updating an input method component.
- it was most likely happening with Spell Catcher X 10.3 (not 10.2.x) because Spell Catcher’s input method now has input modes.
- only Carbon apps were affected - usually older ones - although not restricted to unbundled ones or those that didn't support input methods at all.
- it was something that the Mac OS itself was doing, since there are no public APIs - even in Leopard's new Text Input Sources stuff - that could be used to disable (as in "gray out") an input source in the Input menu.

Here's something quite different for you to try - and again, I have no clue whether it will help. But it won't do any harm.

There's a way to force Spell Catcher X 10.3.x to re-install its input method component. This was useful during beta testing, and extremely useful for my own development. Sometimes I've seen it clear up unusual behavior caused by the various input method-related bugs in Leopard. So try this:

1. Quit the Spell Catcher app if it's open.
2. In the Finder, double-click the Spell Catcher app to launch it directly (i.e. not indirectly by selecting Spell Catcher from the Input menu).
3. Hold down the control key (and only the control key) right after the double-click. Keep holding it down, you should see the alert about updating the input method component (even though the old and new versions are the same).
4. Do the component update, you'll get the "Spell Catcher must restart" alert, click the button to Restart Spell Catcher, and see if that alone does the trick.

You WILL have to restart at some point after doing this (hint: read the alert before clicking the button to Restart Spell Catcher). If the problem seems to be cleared up before you restart, that will be interesting information for me to know. If it doesn't, well, Restart and see if it helped at all.

#11 Rick

Rick

    Member

  • Members
  • PipPip
  • 16 posts
  • Gender:Male
  • Location:Gainesville, FL

Posted 31 October 2008 - 08:29 AM

Here's something quite different for you to try - and again, I have no clue whether it will help. But it won't do any harm.

There's a way to force Spell Catcher X 10.3.x to re-install its input method component. This was useful during beta testing, and extremely useful for my own development. Sometimes I've seen it clear up unusual behavior caused by the various input method-related bugs in Leopard. So try this:

1. Quit the Spell Catcher app if it's open.
2. In the Finder, double-click the Spell Catcher app to launch it directly (i.e. not indirectly by selecting Spell Catcher from the Input menu).
3. Hold down the control key (and only the control key) right after the double-click. Keep holding it down, you should see the alert about updating the input method component (even though the old and new versions are the same).
4. Do the component update, you'll get the "Spell Catcher must restart" alert, click the button to Restart Spell Catcher, and see if that alone does the trick.

You WILL have to restart at some point after doing this (hint: read the alert before clicking the button to Restart Spell Catcher). If the problem seems to be cleared up before you restart, that will be interesting information for me to know. If it doesn't, well, Restart and see if it helped at all.


This WORKED. After I did step 4 and read the directions on that dialog, I elected to quit my running apps (but none of the offending apps were running) and restart the computer. After the restart, SC was active. I opened up Mail and Firefox and as usual and expected, SC was still working. Now for an offending Cocoa app. Open Word and SC is still active! Open Entourage and it is still active! I will keep them open and toggle through them as I typically do but continue to look at SC's status and report back. However, we're off to a great start!

Incidentally, one point that may be helpful in your diagnostics. In the SC 10.3 or 10.3.1 instructions, it mentions needing to drag a component out of a folder and back in for the system to recognize the change or availability of the updated component. I had to do that step originally. Just another data point.

Here's hoping....

Rick

#12 Stu_C

Stu_C

    Member

  • Members
  • Pip
  • 1 posts

Posted 31 December 2008 - 02:51 PM

I experienced the same problem and it took the control-key 'trick' to get the SC check-mark input method to stick. I had to click the activate/deactivate/activate buttons a number of times before anything happened. I also experienced an inability to add applications in the preferences pane and had to use a 'work around' of changing a setting from the input-method menu.

I was using v10.2-something and had no problems. I "up"graded only because of the urgings on the Rainmaker site and e-mailings. I've been using this product since the days of "Thunder!" and have had no problems until now. My confidence is being shaken.

Stuart

#13 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 10 April 2009 - 09:50 PM

I experienced the same problem and it took the control-key 'trick' to get the SC check-mark input method to stick. I had to click the activate/deactivate/activate buttons a number of times before anything happened. I also experienced an inability to add applications in the preferences pane and had to use a 'work around' of changing a setting from the input-method menu.

I was using v10.2-something and had no problems. I "up"graded only because of the urgings on the Rainmaker site and e-mailings. I've been using this product since the days of "Thunder!" and have had no problems until now. My confidence is being shaken.

Stuart


Realize this happens because of bugs in Leopard. Maybe you should say "My confidence in Apple is being shaken."

Apple found six different bugs in Leopard (from my reports and technical incident) related to input method "discovery". Most have been fixed, but there are a couple of critical ones that won't be until Snow Leopard (fingers crossed).

All of them require fixing for things to work properly.