Jump to content


Photo

Can't save learned words.


  • Please log in to reply
4 replies to this topic

#1 Golfersal

Golfersal

    Member

  • Members
  • PipPip
  • 22 posts

Posted 10 February 2009 - 08:51 AM

Everytime I shut down spell catcher up comes a warning

The document "U.S. English - My Learned World.learned" could not be saved.

Why is that coming up and what does it mean?

All of my recent new enteries into spell catcher aren't getting saved.

What changed all of this and how do I save stuff with the other stuff I have been saving for years.

#2 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 10 February 2009 - 08:26 PM

Everytime I shut down spell catcher up comes a warning

The document "U.S. English - My Learned World.learned" could not be saved.

Why is that coming up and what does it mean?

All of my recent new enteries into spell catcher aren't getting saved.

What changed all of this and how do I save stuff with the other stuff I have been saving for years.


Did you recently upgrade from Tiger to Leopard? This seems to be a (very rare) problem in this situation. I've seen it myself, but for the life of me could not pinpoint the cause. Something related to the different way that ownership and permissions are implemented on Leopard.

Here's the easiest way to deal with it - should work, let me know if it doesn't. There are other ways, but they involve more steps.

In the Spell Catcher app, choose Spell Catcher > Spelling References.
Click the disclosure triangle to the left of the US English language.
Double-click "U.S. English - My Learned Words.learned" in the list to open/edit it.
Choose File > Save As.
Leave the name alone, when asked if you want to replace, click the Replace button.

Now test whether this worked - simply choose File > Save. If you don't get an error, you should be all set.

Do the same if you discover other files that show an error when attempting to save them.

#3 Golfersal

Golfersal

    Member

  • Members
  • PipPip
  • 22 posts

Posted 12 February 2009 - 06:50 AM

Did you recently upgrade from Tiger to Leopard? This seems to be a (very rare) problem in this situation. I've seen it myself, but for the life of me could not pinpoint the cause. Something related to the different way that ownership and permissions are implemented on Leopard.

Here's the easiest way to deal with it - should work, let me know if it doesn't. There are other ways, but they involve more steps.

In the Spell Catcher app, choose Spell Catcher > Spelling References.
Click the disclosure triangle to the left of the US English language.
Double-click "U.S. English - My Learned Words.learned" in the list to open/edit it.
Choose File > Save As.
Leave the name alone, when asked if you want to replace, click the Replace button.

Now test whether this worked - simply choose File > Save. If you don't get an error, you should be all set.

Do the same if you discover other files that show an error when attempting to save them.



It still won't let me save it. I get this warning"
The document “U.S. English - My Learned Words.learned” could not be saved as “U.S. English - My Learned Words”.

#4 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 12 February 2009 - 07:14 PM

It still won't let me save it. I get this warning"
The document “U.S. English - My Learned Words.learned” could not be saved as “U.S. English - My Learned Words”.


Is that the exact wording of the error? Please double-check, as that's not something I've seen.

What version of Mac OS X are you using?

What version of Spell Catcher X?

In the Finder's Advanced Preferences, do you have to option to "Show all file extensions" selected? When you choose Save As, does it make any difference if you toggle the setting of the "Hide Extension" checkbox?

#5 Golfersal

Golfersal

    Member

  • Members
  • PipPip
  • 22 posts

Posted 14 February 2009 - 09:22 AM

Is that the exact wording of the error? Please double-check, as that's not something I've seen.

What version of Mac OS X are you using?

What version of Spell Catcher X?

In the Finder's Advanced Preferences, do you have to option to "Show all file extensions" selected? When you choose Save As, does it make any difference if you toggle the setting of the "Hide Extension" checkbox?



Gosh this way of getting help drives me crazy, takes days to fix.
I am using os 10.5.6
I am using Spell Catcher 10.3.2

I started seeing this problem a couple of months ago, seems that I can't record any of my words or shorthand items. The message comes everytime I reboot the computer or shut down Spell Catcher

Yes I have show all file extensions selected


Have just fixed the problem.

Called up file U.S. English-My learned Worlds.Learned

Hit optionI and some of the permissions were write only. Have no idea how this happened but I have been having problems with some applications in loading new software and such.

I hate all of these permission things on os x
For the average person like me I don't understand this and don't want to understand it. This is my computer and I don't share it or any files on a server so to have to go through hoops on this is not right
thanks