Jump to content


Photo

Help


  • Please log in to reply
1 reply to this topic

#1 larrymcj

larrymcj

    Member

  • Members
  • PipPip
  • 13 posts

Posted 10 July 2009 - 05:53 PM

Evan,

I really need some help here. I gave up trying to my problems and uninstalled SC per your FAQ, but now whenever I use Gmail (with Safari or any other browser) anything I try to type gives me an alert that it can't find Spell Checker. I can't use my email!!

I did exactly what the FAQ uninstaller told me to do, including reboot but it doesn't make any difference. I'm leaving on a trip and now I don't have any email. PLEASE answer this and help me. I can receive email, I just can't type in Gmail for all the alerts that it's giving me that it's trying to contact Spell Checker. Please also send your reply to larry@mcjunkin.net as your notification feature doesn't work for me in the forums so I won't know when you reply.

Larry McJunkin

#2 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 10 July 2009 - 06:25 PM

Evan,

I really need some help here. I gave up trying to my problems and uninstalled SC per your FAQ, but now whenever I use Gmail (with Safari or any other browser) anything I try to type gives me an alert that it can't find Spell Checker. I can't use my email!!

I did exactly what the FAQ uninstaller told me to do, including reboot but it doesn't make any difference. I'm leaving on a trip and now I don't have any email. PLEASE answer this and help me. I can receive email, I just can't type in Gmail for all the alerts that it's giving me that it's trying to contact Spell Checker. Please also send your reply to larry@mcjunkin.net as your notification feature doesn't work for me in the forums so I won't know when you reply.

Larry McJunkin


Here's the reply I just sent via email:

Sounds like the Mac OS X system-wide spelling service is set to use a Spell Catcher language.

First, make sure the uninstall went properly - in the Finder, navigate to your HOME ~/Library/Services folder. Make sure there's no file named "Spell Catcher Services.service". If there is, trash it.

If that's not it, then try this: In Safari, place the insertion point in a text field - either the address bar or google search field will do. Then choose Edit > Spelling and Grammar > Show Spelling and Grammar (command-:). You might get the same alert, just be patient and wait for it, then hopefully the spelling panel will open. If there's no language selected, choose one. If there is a language selected, and it's not the one you want, select the one you want. If it is the one you want, select some other one, then re-select your language.

It may also help if you first deselect Edit > Spelling and Grammar > Check Spelling while Typing until this gets sorted out.

If none of that pans out, you need to either edit or trash your home ~/Library/Preferences/.GlobalPreferences.plst file. The trick here is that this file is not visible in the Finder, as the name begins with a period (.). Many text editors, like BBEdit, can open hidden files. In a pinch, you can delete it via the Terminal (in Applications/Utilities) with the following command:

rm ~/Library/Preferences/.GlobalPreferences.plist

(off the top of my head)

Then restart right away.