Jump to content


Photo

SpellCatcher not working well with Firefox and NeoOffice


  • Please log in to reply
4 replies to this topic

#1 ddoer

ddoer

    Member

  • Members
  • PipPip
  • 14 posts

Posted 18 August 2009 - 11:40 AM

I just upgraded from Tiger to Leopard (latest rev) and am running 10.3.2

Under Tiger (PowerPC chip) I always had major problems using Firefox with NeoOffice; if I have abbreviation "/ny" set to expand to "New York" I would get the result "/nyNewYork" in my document.

Now I'm getting that same problem with FireFox 3.5.2 (latest).

Note-- this is a different Firefox problem than what Evan helped out on (so nicely!!) a while back:
https://bugzilla.moz...g.cgi?id=482457

Any thoughts? I have an old email from you that mentions something about Java input method, but I did a search on your FAQ and don't see much that sounds relevant about that.

On the flip side... SpellCatcher seems to be working nicely with iCal; it was never safe to expand abbreviations there previously! Or am I incorrect on that?

As always, many thanks!!

#2 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 19 August 2009 - 04:09 PM

I just upgraded from Tiger to Leopard (latest rev) and am running 10.3.2

Under Tiger (PowerPC chip) I always had major problems using Firefox with NeoOffice; if I have abbreviation "/ny" set to expand to "New York" I would get the result "/nyNewYork" in my document.

Now I'm getting that same problem with FireFox 3.5.2 (latest).

Note-- this is a different Firefox problem than what Evan helped out on (so nicely!!) a while back:
https://bugzilla.moz...g.cgi?id=482457

Any thoughts? I have an old email from you that mentions something about Java input method, but I did a search on your FAQ and don't see much that sounds relevant about that.

On the flip side... SpellCatcher seems to be working nicely with iCal; it was never safe to expand abbreviations there previously! Or am I incorrect on that?

As always, many thanks!!


Try the solution for NeoOffice that's attached to this post.

Highly unlikely that the underlying issue in NeoOffice is the same as that in Firefox.

I'll take a closer read and look at what you're saying about Firefox and that this problem is different from the reported ones.

As for iCal, I don't ever recall expansions were in any way "unsafe." iCal and Address Book can have odd keyboard focus issues due to their "unusual" text editing views, but not sure what was unsafe about them.

#3 ddoer

ddoer

    Member

  • Members
  • PipPip
  • 14 posts

Posted 27 August 2009 - 07:10 AM

Thanks much, the combination of the Input Method Tuner and also application-specific configuration (unchecking the "Make Replacements directly" checkbox in Interactive|Typing) solved the problem for me with both Firefox and NeoOffice.

Note-- Input Method itself made no difference... when I then unchecked "Make Replacements directly" it worked immediately. Should I delete/uninstall the Input Method Tuner for any reason (if all seems to be working now)??

Thanks again for the great tech support... I'm just now got the time to make the fix!

#4 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 27 August 2009 - 11:06 AM

Thanks much, the combination of the Input Method Tuner and also application-specific configuration (unchecking the "Make Replacements directly" checkbox in Interactive|Typing) solved the problem for me with both Firefox and NeoOffice.

Note-- Input Method itself made no difference... when I then unchecked "Make Replacements directly" it worked immediately. Should I delete/uninstall the Input Method Tuner for any reason (if all seems to be working now)??

Thanks again for the great tech support... I'm just now got the time to make the fix!


You need the tuner bundle for NeoOffice 3.x compatibility. It's not needed for Firefox.

#5 ddoer

ddoer

    Member

  • Members
  • PipPip
  • 14 posts

Posted 27 August 2009 - 11:08 AM

OK, sounds like I'm good to go. Thanks again.