Jump to content


Photo

Canít keep 10.3.3 active


  • Please log in to reply
21 replies to this topic

#1 rmathes

rmathes

    Member

  • Members
  • PipPip
  • 27 posts

Posted 18 January 2010 - 07:16 AM

just installed the new version of SC. Hopefully I installed it correctly, it was a little confusing. It said I could install one thing, or two things and recommended installing the two things but one of the things was greyed out but checked and wouldnít let me check or uncheck it. I donít remember the exact names of the two options. So I hit install and it seemed to do its thing. 10.3.3 is now the version thatís running and when the input method is active, I've got the yellow check with the Ď64í above.

The problem is that the input method doesnít stay selected. It will go for stretches where it does, then it will turn back to the flag and I have to reset it again.

Do I still need to run the Activator?

Is there something else I havenít done? I havenít set Mail and Safari back to 64 bit yet, just wanted to see how this works, but I'm presuming that I should be able to do so.

Would appreciate any advice on getting the input method to stay selected.

And FYI, I had this problem with 10.3.2 as well, even after following Evanís instructions and changing these apps to 32 bit under Snow Leopard. Iíd run Activator, the input method would sometimes stay on, then sometimes revert back to the flag. Very rarely had this issue prior to Snow Leopard.

#2 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 19 January 2010 - 02:05 AM

just installed the new version of SC. Hopefully I installed it correctly, it was a little confusing. It said I could install one thing, or two things and recommended installing the two things but one of the things was greyed out but checked and wouldnít let me check or uncheck it. I donít remember the exact names of the two options. So I hit install and it seemed to do its thing. 10.3.3 is now the version thatís running and when the input method is active, I've got the yellow check with the Ď64í above.

The problem is that the input method doesnít stay selected. It will go for stretches where it does, then it will turn back to the flag and I have to reset it again.

Do I still need to run the Activator?

Is there something else I havenít done? I havenít set Mail and Safari back to 64 bit yet, just wanted to see how this works, but I'm presuming that I should be able to do so.

Would appreciate any advice on getting the input method to stay selected.

And FYI, I had this problem with 10.3.2 as well, even after following Evanís instructions and changing these apps to 32 bit under Snow Leopard. Iíd run Activator, the input method would sometimes stay on, then sometimes revert back to the flag. Very rarely had this issue prior to Snow Leopard.


No, the Activator is not needed, and won't do anything anyway if the version of Spell Catcher that's running isn't 10.3.2. Feel free to trash it.

Check the following:

1. In Language & Text System Preferences, Input Sources tab, make sure that your input source options are set to "Use the same one in all documents".
2. In the list of input sources, make sure that Spell Catcherís input method application (yellow checkmark with the little "64" badge is turned "On". There's generally no need to have the input method component (plain yellow checkmark) turned on. So if it's "On" as well, turn it off.

Realize that the Mac OS will forcibly select a keyboard at certain times - generally when you have to enter an admin password in an authentication dialog. It should automatically re-select the previously active input source once the auth dialog closes, though.

You may also want to check the keyboard shortcuts that are assigned to switch input sources. If they are set to shortcuts you may accidentally type, think about changing them. Disable them entirely if you wish, but they can be very useful.

Let me know your experiences and results, I should probably create a FAQ for this as a few folks are writing in with the same basic question.

#3 rmathes

rmathes

    Member

  • Members
  • PipPip
  • 27 posts

Posted 19 January 2010 - 07:35 AM

Evan, thanks. I didnít have ďuse the same one in all documentsĒ enabled. Since checking that, it appears more stable. Will report back after more usage, but so far so good.

Also, in the input list for SC I have 3 options to check or not check: SC, SC Cyrillic, and SC Unicode. The first and last are checked. Not sure what the Unicode option is. Does that need to be checked?

#4 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 19 January 2010 - 07:42 AM

Evan, thanks. I didnít have ďuse the same one in all documentsĒ enabled. Since checking that, it appears more stable. Will report back after more usage, but so far so good.

Also, in the input list for SC I have 3 options to check or not check: SC, SC Cyrillic, and SC Unicode. The first and last are checked. Not sure what the Unicode option is. Does that need to be checked?


I posted a new FAQ on the topic.

If you use a Unicode keyboard like U.S. Extended, you might want to use Spell Catcher Unicode input mode. If not, you can turn it off.

Not sure why it's getting turned on for some folks, might simply be that all keyboards on Snow Leopard are Unicode-savvy, though it's a bit of a mystery why Spell Catcher is classifying some that don't generate Unicodes outside of the standard Roman range are being classified that way. Seems that the behavior of these APIs (deprecated on Snow Leopard, but should still work the same as on previous versions of Mac OS X) to classify a keyboard has changed since I started working on Snow Leopard.

Yet another thing to look into.

#5 tbailey

tbailey

    Member

  • Members
  • PipPipPip
  • 118 posts

Posted 19 January 2010 - 09:58 AM

Check the following:

1. In Language & Text System Preferences, Input Sources tab, make sure that your input source options are set to "Use the same one in all documents".


FYI, even though I have not experienced any problems since installing 10.3.3, I wanted to let you know that my option to "Use the same input for all documents" was not set either. I believe we were told to manually check this when we were using the Activator for the prior version. This tells me that the installation does not (always) change it to the above setting, and we are not instructed to manually do this in any of the installation instructions of 10.3.3. So if it is important and can cause an issue, we should at least be told do this during the installation process.

Also, my SCX Unicode option was also checked, like I said, I have not experienced any issues (but I am a relatively lite-straight forward user), but I can confirm I had two out of the three input option of SCX checked as well.

For what its worth,
Tom
Aluminum Powerbook 13"
Snow Leopard 10.6.2

#6 rmathes

rmathes

    Member

  • Members
  • PipPip
  • 27 posts

Posted 19 January 2010 - 10:03 AM

Thanks Evan.

How would I know if I'm using a Unicode extended keyboard? I have no idea what that means.

Iím using the wired Apple aluminum thin keyboard that has function keys up top and a separate numeric keypad to the side.

#7 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 19 January 2010 - 11:22 AM

Thanks Evan.

How would I know if I'm using a Unicode extended keyboard? I have no idea what that means.

Iím using the wired Apple aluminum thin keyboard that has function keys up top and a separate numeric keypad to the side.


When I say "Keyboard", usually I'm talking about input sources..

In the Finder, choose Help > Mac Help, search for "input source", "Input menu", "input method" and read all about it.

#8 kitmosden

kitmosden

    Member

  • Members
  • PipPip
  • 19 posts

Posted 27 January 2010 - 02:01 AM

I'm having the same problems with SC not staying activated. And when I go to Language & Text System Preferences, Input Sources, I find 2 sets of SC prefs, but I donít know how to delete one of the sets. I tried throwing away 10.3.2 but that didnít help.

#9 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 27 January 2010 - 06:50 AM

I'm having the same problems with SC not staying activated. And when I go to Language & Text System Preferences, Input Sources, I find 2 sets of SC prefs, but I donít know how to delete one of the sets. I tried throwing away 10.3.2 but that didnít help.


Please don't use Spell Catcher X 10.3.2 on Snow Leopard. Update to 10.3.4, it's free, and works much better on 10.6.

Then read this FAQ.

#10 rmathes

rmathes

    Member

  • Members
  • PipPip
  • 27 posts

Posted 27 January 2010 - 06:59 AM

with the new version and Evanís advice on settings above, SC has been rock solid for me ever since. I havenít had to manually change the input method once. I think that one setting in system preferences about retaining the input method was key.

#11 kitmosden

kitmosden

    Member

  • Members
  • PipPip
  • 19 posts

Posted 27 January 2010 - 12:19 PM

Please don't use Spell Catcher X 10.3.2 on Snow Leopard. Update to 10.3.4, it's free, and works much better on 10.6.

Then read this FAQ.



Hi Evan,

I am using 10.3.4 but have 2 copies is of SC in the Language & Text System Preferences, Input Sources.

Cheers,

Kit

#12 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 27 January 2010 - 12:27 PM

Hi Evan,

I am using 10.3.4 but have 2 copies is of SC in the Language & Text System Preferences, Input Sources.

Cheers,

Kit

There are two input methods - so what you see may be OK. Look closely at the screenshot in the FAQ. The Input method application (for 64-bit Snow Leopard) has a small "64" badge on the yellow checkmark icon, the input method component doesn't.

If that's what you see, generally you'll have the input method application turned "On", and the input method component Off.

If that's not what you see, post a screenshot.

#13 kitmosden

kitmosden

    Member

  • Members
  • PipPip
  • 19 posts

Posted 04 February 2010 - 02:20 AM

Please don't use Spell Catcher X 10.3.2 on Snow Leopard. Update to 10.3.4, it's free, and works much better on 10.6.

Then read this FAQ.


Hi Evan,

I've tried everything mentioned here but still can't keep 10.3.4 active. I have even had SC deselect itself (in menu bar) in the middle of a sentence.

#14 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 04 February 2010 - 09:47 PM

Hi Evan,

I've tried everything mentioned here but still can't keep 10.3.4 active. I have even had SC deselect itself (in menu bar) in the middle of a sentence.

Have you assigned keyboard shortcuts for switching input sources? If so, any chance you're typing one of them?

#15 kitmosden

kitmosden

    Member

  • Members
  • PipPip
  • 19 posts

Posted 05 February 2010 - 01:01 AM

Have you assigned keyboard shortcuts for switching input sources? If so, any chance you're typing one of them?



No but I suppose itís possible I have a conflicting keyboard command somewhere. Iíll have to look for that.

Thanks,

Kit

#16 oconnor4d

oconnor4d

    Member

  • Members
  • Pip
  • 5 posts

Posted 05 February 2010 - 11:35 AM

Hi Evan,

I've tried everything mentioned here but still can't keep 10.3.4 active. I have even had SC deselect itself (in menu bar) in the middle of a sentence.



I just updated to 10.3.4 and I can't keep SC active. I have read the FAQ and checked through everything mentioned. My macbook is not 64 bit enabled. SC goes inactive whenever I shift to the Finder, AND the SC option in the menubar goes blank/gray when in Finder mode (it can't be selected.) If I only shift through applications, SC will stay active.


Also, the input source keyboard shortcuts (e.g. command-space) seem to be the system default for spotlight (and I do not have them active for spell checker.)

Dennis

#17 oconnor4d

oconnor4d

    Member

  • Members
  • Pip
  • 5 posts

Posted 05 February 2010 - 12:11 PM

Also, in About Spell Checker, it indicates input method component version as 10.3.4 build 1, but when I check in my user library component folder, I find spell checker component 10.3.3 (created 1/20/2010). Is this right?

#18 oconnor4d

oconnor4d

    Member

  • Members
  • Pip
  • 5 posts

Posted 05 February 2010 - 12:20 PM

I reinstalled, AND restarted, the component is now 10.3.4, and SC is working properly.

Dennis

#19 kitmosden

kitmosden

    Member

  • Members
  • PipPip
  • 19 posts

Posted 05 February 2010 - 03:36 PM

No but I suppose it’s possible I have a conflicting keyboard command somewhere. I’ll have to look for that.

Thanks,

Kit


The conflict appears to be LaunchBar which uses Command Spacebar but I can’t see, offhand, what the conflict is with SpellCatcher????
And no I don’t use Command Spacebar for Spotlight.

#20 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 05 February 2010 - 04:35 PM

The conflict appears to be LaunchBar which uses Command Spacebar but I canít see, offhand, what the conflict is with SpellCatcher????
And no I donít use Command Spacebar for Spotlight.

Command-space is the default keyboard shortcut for switching the active input source. Open Language & Text System Preferences, Input Sources tab, change it to something else or disable it.

This is a Mac OS X shortcut - nothing to do with Spell Catcher in particular.