Jump to content


Photo

Adding New Shorthands Fast


  • Please log in to reply
3 replies to this topic

#1 jackl73

jackl73

    Member

  • Members
  • PipPip
  • 20 posts

Posted 12 March 2010 - 01:20 PM

When I want to set up a new shorthand entry, e.g. sul for See you later, how do I do it from the Suggest Spelling Window.

When I type ‘sul’ the SCX Questionable Spelling Window opens. How do I enter ‘See you later.’ without going to the SCX references window and clicking on My Shorthands?

Currently the Shorthand button is greyed out?

I know I am doing something wrong but cannot work out what.


Look forward to hearing from you. Regards, Jack

#2 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 13 March 2010 - 01:19 AM

When I want to set up a new shorthand entry, e.g. sul for See you later, how do I do it from the Suggest Spelling Window.

When I type ‘sul’ the SCX Questionable Spelling Window opens. How do I enter ‘See you later.’ without going to the SCX references window and clicking on My Shorthands?

Currently the Shorthand button is greyed out?

I know I am doing something wrong but cannot work out what.


Look forward to hearing from you. Regards, Jack

Enter the expansion into the "Use:" text field.

NOTE: This requires making the Suggest Spelling Window the "key" window (active/focused/destination for keystrokes). You may have to click the title bar or choose the Suggest Spelling command from the Input menu again.
KNOWN ISSUE: There are problems when the Suggest Spelling Window becomes key when using the input method application (yellow checkmark with "64" badge). Basically, it just doesn't work right (as of Spell Catcher X 10.3.4). This will be fixed in the next update. Don't ask me for an estimated release date, but development is quite far along. I haven't seeded my beta tester with it yet, but I am aiming for sooner rather than later.
HOWEVER, this works just fine with the input method component (plain yellow checkmark).


As well, if the expansion you want to use appears in the list of suggestions, you can select it and the Shorthand button will be enabled.

Tip: Hover the mouse over the Shorthand button to either find out why it's disabled, or preview the actual shorthand that will be added if it is enabled.

#3 jackl73

jackl73

    Member

  • Members
  • PipPip
  • 20 posts

Posted 15 March 2010 - 07:10 AM

Euan,

The older Spell Catcher (plain yellow tick) works fine. But I cannot get the old version to stick. It keeps dropping out or reverting to the ‘64’ version. Again what do you think I am doing wrong or how can I correct this.

It might be connected to a problem I have with SC not always loading when I start an application like Apple Mail although there is no restriction on using SC with Mail.

Hope all is well. And look forward to hearing from you. Thanks and regards, Jack

#4 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 16 March 2010 - 06:58 PM

Euan,

The older Spell Catcher (plain yellow tick) works fine. But I cannot get the old version to stick. It keeps dropping out or reverting to the ‘64’ version. Again what do you think I am doing wrong or how can I correct this.

It might be connected to a problem I have with SC not always loading when I start an application like Apple Mail although there is no restriction on using SC with Mail.

Hope all is well. And look forward to hearing from you. Thanks and regards, Jack

If you want to always use the input method component with a particular (32-bit mode) app, open Spell Catcher’s Preferences, Interactive pane, Typing tab. Select that app in the list in the Applications, drawer, and select "Use input method component in this application where possible".