Jump to content


Photo

How do I stop SC from loading at startup?


  • Please log in to reply
5 replies to this topic

#1 rmathes

rmathes

    Member

  • Members
  • PipPip
  • 27 posts

Posted 26 December 2010 - 11:45 AM

Unfortunately, and at least for now, I have to stop running SC. I've been using it for 5 years now but I'm just having too many conflicts with other apps, have to switch to an alternative, something I'm not happy doing but it is what it is.

I've disabled the input method and SpellCatcher is no longer in my list of items to load automatically at login, but it's still loading when I reboot. How do I stop that behavior?

#2 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 26 December 2010 - 11:27 PM

Unfortunately, and at least for now, I have to stop running SC. I've been using it for 5 years now but I'm just having too many conflicts with other apps, have to switch to an alternative, something I'm not happy doing but it is what it is.

I'd love to hear more details about these "conflicts". Really shouldn't be happening, or should be easy solutions for almost all of them.

I've disabled the input method and SpellCatcher is no longer in my list of items to load automatically at login, but it's still loading when I reboot. How do I stop that behavior?

First off, Spell Catcher should never be in your list of login items. Not necessary.

Anyway, use the Spell Catcher Uninstaller to uninstall it. You can download it separately from our Downloads page, and it's on the installation disk image as well.

#3 rmathes

rmathes

    Member

  • Members
  • PipPip
  • 27 posts

Posted 27 December 2010 - 06:34 AM

Evan, is there a way to keep SC from loading at startup without uninstalling it? Would like to be able to periodically update and re-test the app.

one of the conflicts is one I emailed you about previously, slow typing in OmniFocus. That never did resolve.

Would also get Safari to hang and then crash when I was typing at least once a day.

Then we have a couple of proprietary java apps where when entering text into fields to create a new client I'd see funky behavior. at first I thought it was the apps themselves, but all these behaviors instantly disappeared when I disabled SC.

#4 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 27 December 2010 - 09:24 AM

Evan, is there a way to keep SC from loading at startup without uninstalling it? Would like to be able to periodically update and re-test the app.

Sure, make sure Spell Catcher is not selected in the Input menu when you Restart. As well, open Spell Catcher Preferences, Language pane, deselect Mac OS X spelling checker: "Can use Spell Catcher’s languages and word lists", then log out and in again.

one of the conflicts is one I emailed you about previously, slow typing in OmniFocus. That never did resolve.

Not sure if it's possible to fix it on my end. You might want to try using the input method component with it (Interactive preferences, Typing tab).

Would also get Safari to hang and then crash when I was typing at least once a day.

In Safari, deselect Edit > Spelling and Grammar > Check Spelling while typing (WebKit bug)

Then we have a couple of proprietary java apps where when entering text into fields to create a new client I'd see funky behavior. at first I thought it was the apps themselves, but all these behaviors instantly disappeared when I disabled SC.


Again, for these java apps, try selecting to use the input method component with them. This FAQ explains basically how to do that.

#5 rmathes

rmathes

    Member

  • Members
  • PipPip
  • 27 posts

Posted 28 December 2010 - 10:25 PM

Evan, thanks.

I've tried doing what that FAQ suggests and i've got a problem. When I go to the language prefs and try to enable the non-64 input method for SC, that option does not exist. I'm running the latest versions of both SC and Snow Leopard.

Also,I'm typing this in Chrome and it ain't behaving well. When there's a correction made,I lose proper spacing, like what you see between the comma and the'I' (or right there,I have it set to auto capitalize the word'I').

And, no change in OmniFocus yet from selecting input component.

#6 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 28 December 2010 - 10:58 PM

Evan, thanks.

I've tried doing what that FAQ suggests and i've got a problem. When I go to the language prefs and try to enable the non-64 input method for SC, that option does not exist. I'm running the latest versions of both SC and Snow Leopard.

Also,I'm typing this in Chrome and it ain't behaving well. When there's a correction made,I lose proper spacing, like what you see between the comma and the'I' (or right there,I have it set to auto capitalize the word'I').

And, no change in OmniFocus yet from selecting input component.

Is Spell Catcher's input method component even installed? Easy to tell - in the Spell Catcher application, choose About Spell Catcher. If you see a little "Install" button for the component (instead of the version that's installed), then click "Install". Should be available after doing that. May NOT be turned "On" in System Preferences by default - you'll have to open Language & Text prefs to the Input Sources tab and turn it on from there (type "spell" in the search field below the list if you can't find it by scrolling). For the Interactive/Typing preference to "Use the input method component" to actually do anything, the component has to be turned on in the list of input sources.

Still, it's not cleear to me what you're saying by "When I go to the language prefs and try to enable the non-64 input method for SC, that option does not exist" - maybe you can clarify what you're looking for that's no there?