Jump to content


Photo

Why double prefs for suppressing completion key?


  • Please log in to reply
4 replies to this topic

#1 spitfire31

spitfire31

    Member

  • Members
  • Pip
  • 4 posts

Posted 27 December 2010 - 09:41 PM

Hi,

Although I use completions extensively while writing fiction and technical articles, I'm not yet clear about the interaction between the two places where I can apparently select to suppress the activator key (Space in my case).

As the image shows, I can choose to "Always suppress the keystroke that chooses a completion". But in the 'My shorthands' file I still have to select "Don't type separator" for each and every one of my shorthands.

I'd appreciate an explanation of the difference between these two prefs, please. Also, isn't there somwehere I can select to globally suppress the Space activator?

Best,

Joachim

Attached Files



#2 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 28 December 2010 - 03:24 PM

Hi,

Although I use completions extensively while writing fiction and technical articles, I'm not yet clear about the interaction between the two places where I can apparently select to suppress the activator key (Space in my case).

It's not quite clear to me how you're using the Completion feature for shorthands from the screenshot. Since you're not automatically showing completions (Auto? is not selected for anything), or using the number keys to choose one of the top 10 shown, are you therefore manually choosing Complete from the Input menu, then the up/down arrows to select the one you want, followed by enter/return to select? For completions, a pop-up list is always displayed, where no user interface is shown for Shorthand Glossary expansions. Seems to me, with those settings, maybe you're just using shorthands. Hard for me to say for sure, so a little more detail from you would help.

Those completion settings indicate to me that spacebar is not the trigger key you're using. The trigger would be return/enter in this case.

As the image shows, I can choose to "Always suppress the keystroke that chooses a completion". But in the 'My shorthands' file I still have to select "Don't type separator" for each and every one of my shorthands.

I'd appreciate an explanation of the difference between these two prefs, please. Also, isn't there somewhere I can select to globally suppress the Space activator?

Best,

Joachim


There's no global preference to suppress the separator for shorthands (which would be any word separator character, not just space), but you can select it for multiple shorthand entries at once. For instance, Edit > Select All to select all the shorthands in the document, then select Don't type separator. Same goes for the other checkboxes as well.

But still, I'm not so sure that you're strictly using Spell Catcher’s shorthand feature, and not using completion at all…

#3 spitfire31

spitfire31

    Member

  • Members
  • Pip
  • 4 posts

Posted 28 December 2010 - 07:09 PM

Hello Evan,

Thank you very much for replying so quickly!

I'll confess that I jumped straight into Completions without reading the manual, since I discovered that TypeIt4Me didn't work with Spell Catcher.

As the r/h window in the screen dump, 'Swedish - My Shorthands', shows I add long or tricky words (such as Chinese pinyin transcriptions with a lot of 'tone' diacriticals) and then set activation shorthands, such as 'xi'for 'Xiăo Lóng'.

While writing, I activate the word or expression by typing 'xi'and then hitting Space.

But I don't want the Space character (often the full word may be followed by interpunctation, for instance) so I want to suppress it.

I thought that the option in the Interactiv (universal) window to the left in the screen dump, 'Always suppress the keystroke…' would do just that on a global scale – suppress the Space character that I use to trigger the completions. But it seems I may have misunderstood its function, since I always have to select the 'Don't type separator (interactive only)' option in the r/h window to exclude the Space trigger from the completion.

Since I never want the trigger (Space) character to be added to the completion, I thought there might be a global preference to always have that 'Don't type separator…' option selected, but apparently not.

---

While I have your attention, there's an odd thing happening with shorthands like 'Qī​ Zhēn', with the straight tone marker over 'i'.

When I type the activator and trigger, I only get 'Qī​' – the 'Zhēn' part is stripped out! Apparently the 'ī​' character made a normal embedded Space within the Shorthand act as a trigger Space?

I struggled with this until I found that changing the embedded Space character between 'Qī' and​ 'Zhēn' to a Alt+Space character made the shorthand work properly.

I hope I have explained this a bit better than my OP… ;-)

Best regards and thanks again,

Joachim

#4 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 28 December 2010 - 08:43 PM

Hello Evan,

Thank you very much for replying so quickly!

I'll confess that I jumped straight into Completions without reading the manual, since I discovered that TypeIt4Me didn't work with Spell Catcher.

I wasn't aware that TypeIt4Me and Spell Catcher didn't get along (you can run into issues if they both try to expand at the same time, I suppose). Still, it does appear you're confusing the functionality of Spell Catcher's shorthand and completion features. Might be a good idea to read Spell Catcher's Help Book chapters for each...

As the r/h window in the screen dump, 'Swedish - My Shorthands', shows I add long or tricky words (such as Chinese pinyin transcriptions with a lot of 'tone' diacriticals) and then set activation shorthands, such as 'xi'for 'Xiăo Lóng'.

While writing, I activate the word or expression by typing 'xi'and then hitting Space.

Right - that's how shorthands work. While you can set your Completion preferences to display matching shorthands (in a pop-up list), you have to pick the one you want to use by pressing either the number key next to it, selecting it with up/down arrow and pressing return/enter/space, or double-clicking it. If you read the help and give the Complete feature a try, you'll see what I mean. See this forum thread for some ideas.

But I don't want the Space character (often the full word may be followed by interpunctation, for instance) so I want to suppress it.

I thought that the option in the Interactiv (universal) window to the left in the screen dump, 'Always suppress the keystroke…' would do just that on a global scale – suppress the Space character that I use to trigger the completions. But it seems I may have misunderstood its function, since I always have to select the 'Don't type separator (interactive only)' option in the r/h window to exclude the Space trigger from the completion.

Since I never want the trigger (Space) character to be added to the completion, I thought there might be a global preference to always have that 'Don't type separator…' option selected, but apparently not.

That's what works for completions, but not for shorthands (as you've discovered). Like I mentioned, you can set "Don't type separator" for multiple shorthands at once by selecting them in the list, then selecting that checkbox.
---

While I have your attention, there's an odd thing happening with shorthands like 'Qī​ Zhēn', with the straight tone marker over 'i'.

When I type the activator and trigger, I only get 'Qī​' – the 'Zhēn' part is stripped out! Apparently the 'ī​' character made a normal embedded Space within the Shorthand act as a trigger Space?

I struggled with this until I found that changing the embedded Space character between 'Qī' and​ 'Zhēn' to a Alt+Space character made the shorthand work properly.

I hope I have explained this a bit better than my OP… ;-)

Best regards and thanks again,

Joachim


I know there are issues with certain Unicode characters with combining marks, it usually depend on whether they are embedded in the abbreviation or at the beginning or end. I'm not quite sure what's going on with the example you mention - can you create such a shorthand and email the actual file to me so I can see for myself? Send it to our feedback address (choose Help > Send feedback via email in the Spell Catcher application). It's not obvious from your screen shot…

#5 spitfire31

spitfire31

    Member

  • Members
  • Pip
  • 4 posts

Posted 28 December 2010 - 08:53 PM

Thanks for the enlightenment, Evan! Seems I have to RTFM… ;-)

I'll send the troublesome expression.

Thanks again,

Joachim