Jump to content


Photo

Spell Catcher Cyrillic input not working


  • Please log in to reply
3 replies to this topic

#1 dansko

dansko

    Member

  • Members
  • Pip
  • 2 posts

Posted 30 December 2010 - 05:35 AM

When using the Spell Catcher Cyrillic input, the script does not change to a Cyrillic font, even though there are both Latin and Cyrillic characters in the font.

This has been tested with Apple Mail, TextEdit, Skype, etc. same everywhere.

For proper functionality this input method needs to produce Cyrillic characters.

Please advise.
Thank you.

#2 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 30 December 2010 - 03:49 PM

When using the Spell Catcher Cyrillic input, the script does not change to a Cyrillic font, even though there are both Latin and Cyrillic characters in the font.

This has been tested with Apple Mail, TextEdit, Skype, etc. same everywhere.

For proper functionality this input method needs to produce Cyrillic characters.

Please advise.
Thank you.

Just choose a Cyrillic keyboard from the Set Keyboard submenu in Spell Catcher’s input menu. Font is entirely up to you and/or the application. In Snow Leopard (even Leopard), everything is Unicode, really. If a font doesn't contain glyphs for Cyrillic code points, consider it a deficiency in the font.

The old notion of font/keyboard synchronization is, well, a (very) old notion. Not been relevant since the System 7/8 days, really.

#3 dansko

dansko

    Member

  • Members
  • Pip
  • 2 posts

Posted 31 December 2010 - 02:38 PM

Evan thank you! That did the trick!

Just choose a Cyrillic keyboard from the Set Keyboard submenu in Spell Catcher’s input menu. Font is entirely up to you and/or the application. In Snow Leopard (even Leopard), everything is Unicode, really. If a font doesn't contain glyphs for Cyrillic code points, consider it a deficiency in the font.

The old notion of font/keyboard synchronization is, well, a (very) old notion. Not been relevant since the System 7/8 days, really.



#4 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 31 December 2010 - 05:14 PM

Evan thank you! That did the trick!

BTW, this is the recommended way to set things up for those that switch between a Roman/Latin language and a Cyrillic one:

  • Open Language & Text Preferences to the Input Sources tab. Make sure that Spell Catcher's "Spell Catcher" and "Spell Catcher Cyrillic" input modes are "On" (it sounds like this is already done). For now, leave "Spell Catcher Unicode" off (see below*).
  • In Spell Catcher's Preferences, Language pane, select BOTH "Remember language with input mode" and "Remember keyboard layout with input mode". By default, "Remember language..." is deselected (off). TIP: Hover the mouse over each of these checkboxes for a few seconds to learn more about them.
  • Might be a good idea to select "Show current spelling language..." and "Show current keyboard layout..." so a quick look at Spell Catcher's Dock icon will show you what's currently being used.
With these preferences set, you can have Spell Catcher automatically set your keyboard layout and language when you choose one of its modes. To finish the setup, JUST ONCE, you need to do the following:

  • Choose Spell Catcher from the Input menu to activate its Roman/Latin input mode. NOW select your Roman language keyboard (U.S., whatever) from the Set Keyboard submenu (EVEN IF it's already selected!), then select U.S. English from the Set Language submenu (EVEN IF it's already selected). This finishes associating the keyboard and language for this input mode.
  • Choose Spell Catcher Cyrillic input mode from the input menu. Same sort of thing: select your Cyrillic keyboard (Russian, whatever) from the Set Keyboard submenu, and Russian from the Set Language submenu.
Now whenever you switch to one of these Spell Catcher input modes, the language and keyboard will also switch automatically.