Jump to content


Photo

Spell Catcher ramdomly turns itself off


  • Please log in to reply
17 replies to this topic

#1 benos

benos

    Member

  • Members
  • PipPip
  • 25 posts

Posted 12 May 2011 - 07:21 PM

I have a previous similare topic on this. But I started a new topic because I've upgraded my OS and Spellcatcher since that thread.

Currently Spellcatcher v.10.3.7. My previous OS was Tiger, and this problem occurred intermittently with Tiger, and now that I recently upgraded to Leopard (10.5.8), unfortunately the problem is happening more often.

First, after most every resart or log out, SC is not active (it's icon is the American Flag). (SC is selected in the System Prefs/Log-in Items.) So then I turn it on, then at some point throughout the work day, it will be turned off again. I may have to turn it back on 1, 2, or 3 times a day. When it turns itself off it's off in all applications.

Previously, I have removed all applications from SC, it's running on with "Universal."

Any ideas?

Thank you,
Brian

#2 benos

benos

    Member

  • Members
  • PipPip
  • 25 posts

Posted 12 May 2011 - 07:32 PM

After reading some other threads, I had the idea to add an application to CS's prefs, and set it "Use Universal." After a restart and a log out, SC was still active. I'll let you know tomorrow if it randomly quits again, and try to keep my eye out for a pattern.

#3 benos

benos

    Member

  • Members
  • PipPip
  • 25 posts

Posted 13 May 2011 - 06:25 PM

SC turned itself off three times today.

Any workarounds or ideas to make it stay on would be appreciated.

Thank you,
Brian

#4 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 13 May 2011 - 11:02 PM

SC turned itself off three times today.

Any workarounds or ideas to make it stay on would be appreciated.

Thank you,
Brian

You need to give me exact steps to reproduce.

Keep in mind that this will happen when you Quit the Spell Catcher application, if you press the keyboard shortcut to switch input sources unintentionally, and sometimes when you have to enter an admin password.

#5 benos

benos

    Member

  • Members
  • PipPip
  • 25 posts

Posted 14 May 2011 - 08:09 PM

You need to give me exact steps to reproduce.

Keep in mind that this will happen when you Quit the Spell Catcher application, if you press the keyboard shortcut to switch input sources unintentionally, and sometimes when you have to enter an admin password.

I definitely did not do any of those three things.

I'll try to keep a peripheral eye on the "checkmark," to catch when it switches to the "flag," during a days workflow.

Thanks Evan.

#6 benos

benos

    Member

  • Members
  • PipPip
  • 25 posts

Posted 16 May 2011 - 07:10 PM

SC turned itself off twice today, but I was not able to tell exactly when it happened. I have a feeling it might be happening when editing a subject line in Entourage (2004), but I can't say for sure at this point.

But thinking it might be happening in Entourage - I discovered something weird in SC's prefs. I added Entourage to the list of Applications, but when I opened the prefs at the end of the day, Entourage was no longer in the Apps list. So I added it again, closed the prefs, reopened them, and Entourage was not there.

The other day I also added the app TextEdit to the Applications list, and it's no longer their either. So it appears that applications cannot be permanently added to SC's prefs?

#7 benos

benos

    Member

  • Members
  • PipPip
  • 25 posts

Posted 16 May 2011 - 07:13 PM

Also, I have another work machine (also Mac 10.5.8) with SC 10.2.2 installed. SC never turns off on that computer, and it had several apps added to the prefs for some years now.

Is it possible to "backgrade" SC from 10.3.7 to 10.2.2, without losing all my saved shorthands?
be

#8 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 16 May 2011 - 08:52 PM

SC turned itself off twice today, but I was not able to tell exactly when it happened. I have a feeling it might be happening when editing a subject line in Entourage (2004), but I can't say for sure at this point.

But thinking it might be happening in Entourage - I discovered something weird in SC's prefs. I added Entourage to the list of Applications, but when I opened the prefs at the end of the day, Entourage was no longer in the Apps list. So I added it again, closed the prefs, reopened them, and Entourage was not there.

The other day I also added the app TextEdit to the Applications list, and it's no longer their either. So it appears that applications cannot be permanently added to SC's prefs?

This is by design. If you don't actually change a preference for that app, it gets removed.

Attached Files



#9 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 16 May 2011 - 08:56 PM

Also, I have another work machine (also Mac 10.5.8) with SC 10.2.2 installed. SC never turns off on that computer, and it had several apps added to the prefs for some years now.

Is it possible to "backgrade" SC from 10.3.7 to 10.2.2, without losing all my saved shorthands?
be

I would not recommend doing that. It has nothing to do with what is or isn't in Spell Catcherís list of apps in the Preferences drawer. Spell Catcher never "turns itself off" unless you Quit the Spell Catcher application, or click the "Deactivate" button in the Interactive pane of Spell Catcherís Preferences. Only the Mac OS itself will (otherwise) deactivate Spell Catcher as the active input source. You're talking about two different computers here, I would say that something (no idea what) is up on the one you're having problems with. Keep looking for the "event" that triggers this.

#10 benos

benos

    Member

  • Members
  • PipPip
  • 25 posts

Posted 17 May 2011 - 12:09 PM

Thanks for the two followups Evan.

I'll keep an eye out for the "event."

#11 benos

benos

    Member

  • Members
  • PipPip
  • 25 posts

Posted 18 May 2011 - 12:26 PM

I finally, just saw it happen. (SC turned itself off.)

I do the following workflow from 10 to 30 times a day.

Microsoft Office 2004. I pasted an email (body text) from Entourage into an Excel Spreadsheet, clicked a keystroke (Apple + Option + J, that runs a macro), clicked Save As (Apple + Shift +S), entered the text for the file name, and when I clicked the Enter key to complete the Save As, I watched the SC icon's "checkmark" change to the "american flag."

I turned SC back on, and did that same procedure several more times and SC stayed turned on.

More details on "entering the text for the Save As": After clicking Save As, I type the date, formatted as: 05.18, then a space, then I click "Apple +V" to paste (copied text that comes from running the macro) then another space, then type a "$" (dollar sign, which tells me info about the file without having to open it).

As a test, what would you think about adding Excel to SC's app list, make one small change somewhere in the prefs for SC/Excel (so it stays in the apps list), and see if that helps?

#12 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 18 May 2011 - 10:10 PM

I finally, just saw it happen. (SC turned itself off.)

I do the following workflow from 10 to 30 times a day.

Microsoft Office 2004. I pasted an email (body text) from Entourage into an Excel Spreadsheet, clicked a keystroke (Apple + Option + J, that runs a macro), clicked Save As (Apple + Shift +S), entered the text for the file name, and when I clicked the Enter key to complete the Save As, I watched the SC icon's "checkmark" change to the "american flag."

I turned SC back on, and did that same procedure several more times and SC stayed turned on.

More details on "entering the text for the Save As": After clicking Save As, I type the date, formatted as: 05.18, then a space, then I click "Apple +V" to paste (copied text that comes from running the macro) then another space, then type a "$" (dollar sign, which tells me info about the file without having to open it).

As a test, what would you think about adding Excel to SC's app list, make one small change somewhere in the prefs for SC/Excel (so it stays in the apps list), and see if that helps?

No, whether Excel is in the list of apps in preferences is immaterial. And it's not Spell Catcher that's "turning itself off" - it's the Mac OS itself. The only time Spell Catcher will deselect itself in the Input menu is when the Spell Catcher app is quitting, or when it's updating its input methods. Check your International System Preferences, Input Sources tab. See what keyboard shortcuts are set to switch input sources. Any chance you might have inadvertently typed one of them?

#13 benos

benos

    Member

  • Members
  • PipPip
  • 25 posts

Posted 19 May 2011 - 11:44 AM

No, whether Excel is in the list of apps in preferences is immaterial. And it's not Spell Catcher that's "turning itself off" - it's the Mac OS itself. The only time Spell Catcher will deselect itself in the Input menu is when the Spell Catcher app is quitting, or when it's updating its input methods. Check your International System Preferences, Input Sources tab. See what keyboard shortcuts are set to switch input sources.


Would this be a setting you are talking abou: "Select the previous input source"
?

#14 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 19 May 2011 - 09:13 PM

Would this be a setting you are talking abou: "Select the previous input source"
?

Yes - either previous or next. Try them, both will switch the input source. What's it set to? Any chance you're pressing it inadvertently? If so, just change it, or disable it entirely (although it's very handy, so I'd recommend changing it).

#15 benos

benos

    Member

  • Members
  • PipPip
  • 25 posts

Posted 20 May 2011 - 01:33 PM

You are a genius.

The keystroke is Apple + Spacebar, which toggles SC on and off.

I do everything I can with keystrokes, and although I've never intentionally keystroked off SC, I must have brushed those keys occasionally. My hands are always floating just above the keyboard, so that makes sense.

And as far where you told me to look in the System Prefs - that was the first time I'd ever even clicked into the International menu - so thanks for that.

I never want SC to be off, so I deselected that setting.

Thanks, as always, for a great app (that I couldn't live without) and great support.

Brian

#16 Ken Cohen

Ken Cohen

    Member

  • Members
  • Pip
  • 1 posts

Posted 01 July 2011 - 02:38 PM

I donít think that an unintended keyboard shortcut is the answer to this problem. Iíve had the problem for a long time. Something intermittently changes the input source to the Canadian English flag (the Spell Catcher icon goes into second place in the list, in other words it becomes inactive). Whenever I notice it, I have to manually change back to Spell Catcher. I usually first notice it has changed when I try to use a shorthand (which I use often). My keyboard shortcuts for switching the input source are unchecked in Keyboard > Keyboard Shortcuts > Keyboard and text input, and they always have been.

#17 benos

benos

    Member

  • Members
  • PipPip
  • 25 posts

Posted 01 July 2011 - 02:48 PM

Ken,

I can say for sure the answer in my post was definitely the problem for me.

#18 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 04 July 2011 - 02:24 AM

I donít think that an unintended keyboard shortcut is the answer to this problem. Iíve had the problem for a long time. Something intermittently changes the input source to the Canadian English flag (the Spell Catcher icon goes into second place in the list, in other words it becomes inactive). Whenever I notice it, I have to manually change back to Spell Catcher. I usually first notice it has changed when I try to use a shorthand (which I use often). My keyboard shortcuts for switching the input source are unchecked in Keyboard > Keyboard Shortcuts > Keyboard and text input, and they always have been.

This might happen if you are asked to provide an administrator password (although the Mac OS is supposed to restore the input source once the dialog is dismissed). This will happen if you run an application with a user interface that opens with escalated (root) privileges. This is frowned upon (bit time) by Apple. There are some backup utilities that do this. What do you use to backup? You can easily determine the user a process is running for by opening the Activity Monitor utility. See if anything you periodically use does this. If you do see this for a GUI app, think very hard about replacing it with a well-behaved equivalent.