Jump to content


Photo

One-letter words


  • Please log in to reply
1 reply to this topic

#1 Stephen Marcus

Stephen Marcus

    Member

  • Members
  • Pip
  • 1 posts

Posted 05 July 2011 - 02:33 AM

When I go to Mac Mail or TextEdit and type:

a b c d e f

Spell Catcher fails to mark the characters as misspelled words. I have turned off the "ignore one-letter words" feature.

This error also occurs in regular Mac spell checker, and has been around in the PC world for at least ten years.

Why do these spell checkers allow one-letter words?

#2 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 05 July 2011 - 02:57 PM

When I go to Mac Mail or TextEdit and type:

a b c d e f

Spell Catcher fails to mark the characters as misspelled words. I have turned off the "ignore one-letter words" feature.

This error also occurs in regular Mac spell checker, and has been around in the PC world for at least ten years.

Why do these spell checkers allow one-letter words?

How are you using Spell Catcher to check spelling in these apps? Are you using the Mac OS X system-wide spelling checker (i.e. Edit > Spelling and Grammar > Check Spelling and Grammar? In other words, the "red underlines"? Or are you using Spell Catcher’s interactive checking via the input method or Check Selection command? Or Spell Catcher’s DirectCorrect feature?

If the latter, is a Spell Catcher language selected from the popup in the spelling panel (Edit > Spelling and Grammar > Show Spelling and Grammar)? If "Automatic by Language" is selected, then they won't be flagged as errors. If a Spell Catcher language is selected, then they will be marked as errors if you indeed have "ignore one-letter words" deselected.