Jump to content


Photo

Set language per application - iLocalize issue


  • Please log in to reply
18 replies to this topic

#1 Cortig

Cortig

    Member

  • Members
  • PipPip
  • 27 posts
  • Gender:Male
  • Location:Ann Arbor, MI, USA

Posted 09 August 2011 - 03:43 PM

Hi All,

Iím having difficulties setting up the spelling language in one specific application: iLocalize.
By default, SCX uses English no matter what I try. I select a field, set it to French and it all works fine, but as soon as I get to a new field in the application, the selected language is set back to English again.
As it turns out, I never even have to use English in this application, so I tried to edit the preferences in SCX to create an exception for iLocalize. I tried to uncheck the dictionaries for all languages except for French in the preferences, making sure that iLocalize was selected in the Application list, but it looks like the Reference preferences in SCX do not behave like other preferences and any change is Universal.

Any suggestion?

Any idea how I can ask SCX to only use French in iLocalize? (or at least to stick to French once I switched to this language and not reset my selection for every field)

Thanks,

Corentin

Mac Pro Xeon, 4 x 3.0GHz, 8GB RAM, MacOS X 10.7
SCX 10.4

#2 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 09 August 2011 - 06:16 PM

Hi All,

Iím having difficulties setting up the spelling language in one specific application: iLocalize.
By default, SCX uses English no matter what I try. I select a field, set it to French and it all works fine, but as soon as I get to a new field in the application, the selected language is set back to English again.
As it turns out, I never even have to use English in this application, so I tried to edit the preferences in SCX to create an exception for iLocalize. I tried to uncheck the dictionaries for all languages except for French in the preferences, making sure that iLocalize was selected in the Application list, but it looks like the Reference preferences in SCX do not behave like other preferences and any change is Universal.

Any suggestion?

Any idea how I can ask SCX to only use French in iLocalize? (or at least to stick to French once I switched to this language and not reset my selection for every field)

Thanks,

Corentin

Mac Pro Xeon, 4 x 3.0GHz, 8GB RAM, MacOS X 10.7
SCX 10.4


You using the Mac OS X Spelling Panel, or Spell Catcherís interactive checking?

#3 Cortig

Cortig

    Member

  • Members
  • PipPip
  • 27 posts
  • Gender:Male
  • Location:Ann Arbor, MI, USA

Posted 09 August 2011 - 06:59 PM

You using the Mac OS X Spelling Panel, or Spell Catcherís interactive checking?



Sorry, I should have specified: I'm actually using DirectCorrect.

Corentin

#4 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 09 August 2011 - 08:24 PM

Sorry, I should have specified: I'm actually using DirectCorrect.

Corentin

Take a look at the tooltip for "Remember language with input mode" in Spell Catcher Preferences, Language pane.

Possibly applicable?

#5 Cortig

Cortig

    Member

  • Members
  • PipPip
  • 27 posts
  • Gender:Male
  • Location:Ann Arbor, MI, USA

Posted 10 August 2011 - 08:16 AM

Take a look at the tooltip for "Remember language with input mode" in Spell Catcher Preferences, Language pane.

Possibly applicable?



I originally gave it some thought, but I only actually use one input method. I type in French, English and sometimes Spanish so I only use the US Layout for the keyboard no matter what language I type in (using more than one for Roman languages sounds like a good way to develop schizophrenia IMVHO :-> ). Memorizing the shortcuts for accented letters wasnít too hard of an effort.

Any idea why iLocalize 4 is reverting to English for every field? Why isnít SCX remembering that I just selected French in that application?

Corentin

#6 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 11 August 2011 - 04:10 PM

I originally gave it some thought, but I only actually use one input method. I type in French, English and sometimes Spanish so I only use the US Layout for the keyboard no matter what language I type in (using more than one for Roman languages sounds like a good way to develop schizophrenia IMVHO :-> ). Memorizing the shortcuts for accented letters wasnít too hard of an effort.

Any idea why iLocalize 4 is reverting to English for every field? Why isnít SCX remembering that I just selected French in that application?

Corentin

Do you have the preference I mentioned (remember language with input mode) selected? Read the tooltip again - it overrides app-specific settings for language.

#7 Cortig

Cortig

    Member

  • Members
  • PipPip
  • 27 posts
  • Gender:Male
  • Location:Ann Arbor, MI, USA

Posted 11 August 2011 - 04:19 PM

Do you have the preference I mentioned (remember language with input mode) selected? Read the tooltip again - it overrides app-specific settings for language.


I (now) understand what you mean!
I didnít realize I could set this only for iLocalize AND set it to French there as well.

I just tried that and still, SCX reverts to English every time I get into a new field. Iím lost :-\
Am-I missing something?

Posted Image

Corentin

#8 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 11 August 2011 - 04:29 PM

I (now) understand what you mean!
I didnít realize I could set this only for iLocalize AND set it to French there as well.

I just tried that and still, SCX reverts to English every time I get into a new field. Iím lost :-\
Am-I missing something?

Posted Image

Corentin

I think you want to deselect the "Remember languageÖ" preference. Not sure now. What behaviour are you actually after?

#9 Cortig

Cortig

    Member

  • Members
  • PipPip
  • 27 posts
  • Gender:Male
  • Location:Ann Arbor, MI, USA

Posted 12 August 2011 - 08:52 AM

Well I want to have SCX use French (and only French) in iLocalize.
No matter what, I donít understand why SCX reverts back to English systematically in each field even after I changed the setting to French :-\

I originally didnít have the Remember setting checked. Thatís something I tried here after reading your suggestions.

Corentin

#10 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 12 August 2011 - 06:28 PM

Well I want to have SCX use French (and only French) in iLocalize.
No matter what, I donít understand why SCX reverts back to English systematically in each field even after I changed the setting to French :-\

I originally didnít have the Remember setting checked. Thatís something I tried here after reading your suggestions.

Corentin

How is your Language & Text System Preferences, Languages pane, preferred order set?

How are you Spell Catcher Language preferences set for Universal?

#11 Cortig

Cortig

    Member

  • Members
  • PipPip
  • 27 posts
  • Gender:Male
  • Location:Ann Arbor, MI, USA

Posted 12 August 2011 - 06:40 PM

How is your Language & Text System Preferences, Languages pane, preferred order set?

How are you Spell Catcher Language preferences set for Universal?



The System Preferences are set to English, French then Spanish.
I don't want to have the System in French (too many apps are not properly localized and it gets on my nerves :-> )
The SCX preferences for Universal are also set to English (since I mostly communicate in English these days).

Shouldnít-I be able to set iLocalize to French through the application-specific preferences in SCX?

Corentin

#12 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 12 August 2011 - 06:43 PM

The System Preferences are set to English, French then Spanish.
I don't want to have the System in French (too many apps are not properly localized and it gets on my nerves :-> )
The SCX preferences for Universal are also set to English (since I mostly communicate in English these days).

Shouldnít-I be able to set iLocalize to French through the application-specific preferences in SCX?

Corentin

Yes, you should. But now that I know your basic settings I'll find some time to see if I can reproduce the problem.

#13 Cortig

Cortig

    Member

  • Members
  • PipPip
  • 27 posts
  • Gender:Male
  • Location:Ann Arbor, MI, USA

Posted 12 August 2011 - 08:54 PM

Yes, you should. But now that I know your basic settings I'll find some time to see if I can reproduce the problem.



Great! Thanks Evan,

Corentin

#14 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 13 August 2011 - 05:47 PM

Great! Thanks Evan,

Corentin

Hmm, I can't seem to reproduce this in iLocalize 4.1. There is a cosmetic issue on Lion where the language "flag" briefly switches to Canadian English then back to French (for me) when you switch text areas. But the actual language used does "stick" to French.

Any way you can illustrate this via screenshots + steps to reproduce?

#15 Cortig

Cortig

    Member

  • Members
  • PipPip
  • 27 posts
  • Gender:Male
  • Location:Ann Arbor, MI, USA

Posted 15 August 2011 - 03:03 PM

Hmm, I can't seem to reproduce this in iLocalize 4.1. There is a cosmetic issue on Lion where the language "flag" briefly switches to Canadian English then back to French (for me) when you switch text areas. But the actual language used does "stick" to French.

Any way you can illustrate this via screenshots + steps to reproduce?



Not sure what capture/steps I could provide :-\

- launch iLocalize
- Double-click a field in French (a translation) and direct-correct unlines all French words.
- set the language to French.
- Double-click another field (still in French obviously) and SCX reverts to English and elderliness all words until to re-select French.

Attached File  Screen Shot 2011-08-15 at 16.02.32.png   65.58KB   2 downloads

Corentin

#16 Cortig

Cortig

    Member

  • Members
  • PipPip
  • 27 posts
  • Gender:Male
  • Location:Ann Arbor, MI, USA

Posted 15 August 2011 - 03:07 PM

The more I think about this the less I see what I did wrong. I think Iíll go on a serious preference and cache cleanup quest to see if I can get it to work the way it should (or at least the way I believe it should ;-) ),

Corentin

#17 Cortig

Cortig

    Member

  • Members
  • PipPip
  • 27 posts
  • Gender:Male
  • Location:Ann Arbor, MI, USA

Posted 15 August 2011 - 03:13 PM

OKÖ†I rebooted in safe-boot mode to clear up some system cache and tried again. This time, SCX was set to French (and remained so)!!!

Thatís a great relief!
Not sure what cache file was messing things up but I sure am glad I donít have to deal with this anymore :-)

Thanks Evan,

Corentin

#18 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 16 August 2011 - 04:06 PM

OKÖ†I rebooted in safe-boot mode to clear up some system cache and tried again. This time, SCX was set to French (and remained so)!!!

Thatís a great relief!
Not sure what cache file was messing things up but I sure am glad I donít have to deal with this anymore :-)

Thanks Evan,

Corentin

Strange. You're not still in safe mode are you?

#19 Cortig

Cortig

    Member

  • Members
  • PipPip
  • 27 posts
  • Gender:Male
  • Location:Ann Arbor, MI, USA

Posted 16 August 2011 - 05:27 PM

Strange. You're not still in safe mode are you?


No I'm not. I never stay in Safe mode, but I know Safe Booting checks my drive and clears most cache for me, so I've used the trick on occasions to clean things up a bit.

Corentin