Jump to content


Photo

check spelling as you type


  • Please log in to reply
2 replies to this topic

#1 Cat

Cat

    Member

  • Members
  • PipPipPip
  • 69 posts

Posted 27 December 2011 - 03:03 PM

For some reason, SpellCatcher (2.4.1) is not checking spelling automatically as I type and I have no idea how long it has been doing that because I have been taking SpellCatcher for granted for umpteen years now. I have no problems using it, the input method is active, I have interactive features enabled, I have check spelling as you type enabled, but it doesn’t happen. Am I making an obvious error I have forgotten? I do select all the text after I finish typing and do a check selection, so that’s why I’ve probably never noticed that it isn’t working.
I’m using Lion.

#2 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 27 December 2011 - 08:31 PM

What application(s) are you seeing this with? Remember, the settings for Interactive Checking, Check spelling as you type and the like are saved on a per-application basis. Are Shorthand Glossary expansions working? Is the language you expect selected in the Set Language submenu? Same as the Set Keyboard submenu?

Anything "interesting" being output to the Console's system.log?

How are you signalling errors? Via sound/speech/Auto-Show Suggestions?

#3 Cat

Cat

    Member

  • Members
  • PipPipPip
  • 69 posts

Posted 28 December 2011 - 03:01 PM

Thanks, Evan. I didn’t have the set Keyboard the same as Set Language. I also went back and re-read the whole help file. I did this when I first got spell catcher, set it all up how I wanted it and forgot about it. Now I know, again, why it works like it does. Since I didn’t want the flow of my typing interrupted by anything that’s why I set it up to check selection after I type.