Jump to content


Photo

Ghostwriter lag

ghostwriter speed lag

  • Please log in to reply
3 replies to this topic

#1 jefferis

jefferis

    Member

  • Members
  • Pip
  • 2 posts

Posted 26 January 2012 - 10:10 AM

Hi. I have SC 10.3.x and was looking at the improvements in 10.4 but the one I was looking to see was some improvement in the Ghostwriter feature, and didn't see anything about speed. I have a noticeable lag when typing in Outlook and a few other programs when it is turned on, and sometimes I think some keys actually are input to GW but not to the app I'm in because perhaps I'm typing too fast, and a letter drops out of my word . I'm still on Snow Leopard, but have a Quad Core intel with 10G of ram.

Just want to know if you have insight, solutions, improvements to share.

#2 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 26 January 2012 - 09:21 PM

Can you quantify this "lag" in any way? Like "x tenths of a second per character" or "more lag the faster I type"? Something like that?

Are you using Spell Catcher’s input method component (as described in our FAQ) with Outlook?
Does this only affect Outlook?

Ghostwriter tries pretty hard to be conservative when it writes to disk. Are you seeing that disk I/O is heavier when Ghostwriter is turned on?

More changes were made to Ghostwriter in the input method application than the input method component, but neither had any sort of known performance issues...

#3 jefferis

jefferis

    Member

  • Members
  • Pip
  • 2 posts

Posted 05 February 2012 - 03:43 PM

I don't see a link for the input method component in FAQ. http://www.rainmaker....php?category=4
The delay is like .5 seconds per character or so. I type the next character and the previous character appears. I don't know if it increases but I don't think so, cause I type at a steady pace for the most part.
Where would I look for I/O behavior?

#4 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 05 February 2012 - 10:52 PM

Sorry, must have pasted in the wrong link. This is the one I meant, however it's not relevant if you're still using Spell Catcher X 10.3.x.

At any rate, 0.5 seconds per character is an insane amount of delay. Shouldn't happen regardless of Spell Catcher X version or Mac OS X version or application you're using. Something else is going on - can't imagine what.

Do the contents of your Ghostwriter files look OK? Is this restricted to Outlook? What other apps are affected?

All I can think of is that something's "wrong" with the Ghostwriter files or subfolder(s) themselves. Some sort of corruption perhaps?

What is the exact version of Spell Catcher X 10.3.x that you're using? Latest is 10.3.7.

What if you try with a fresh Ghostwriter folder to see if that makes a difference? To do this, you should:
  • Choose a keyboard (flag icon) from the Input menu.
  • Log out and in again, making sure that the Spell Catcher application does not open automatically.
  • In the Finder, navigate to your (home) ~/Library/Application Support/Spell Catcher/ folder.
  • Move the Ghostwriter Folder out onto your Desktop (in case this experiment doesn't work, and there's something in your Ghostwriter folder that you don't want to lose).
  • Now fire up Spell Catcher (choose it from the Input menu).
  • (A new Ghostwriter folder should get created).
See if that helps.