Jump to content


Photo

DirectCorrect & Safari 5.1.5 + snow


  • Please log in to reply
3 replies to this topic

#1 Luie_Tuur

Luie_Tuur

    Member

  • Members
  • Pip
  • 4 posts

Posted 28 April 2012 - 03:23 PM

Hi,

I have a problem with directcorrect and Safari. When starting up Safari I must always activating directcorrect... for other applications it start altways up as the settings are set but never on Safari.
I had this problem never before on Leopard I think.... Do I missing something here?

Kind regards.

#2 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 28 April 2012 - 03:33 PM

I'm pretty sure you're seeing a bug in Safari and/or WebKit.framework on Lion.

When this happens, check the system.log for any "suspicious" output.

I'll have to check, but I think this bug is fixed on Mountain Lion. Unfortunately, you're not missing anything, and there's no work-around.

#3 Luie_Tuur

Luie_Tuur

    Member

  • Members
  • Pip
  • 4 posts

Posted 01 May 2012 - 10:44 AM

Thx Evan,


Sorry for the late response... got a good old fashion holiday

Yes a bug that’s possible. I tried it again and I see this in the stystem.log

May  1 17:36:22: --- last message repeated 2 times ---
May  1 17:36:22 d54c61bc6 SpellCatcherIM[5998]: Spell Catcher Input Method: Turned DirectCorrect off - aborting.
I hope it is fixed on the next Mountain Lion.

Kind regards,

#4 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 01 May 2012 - 09:16 PM

Looks like it's almost OK on the current developer preview build of Mountain Lion (definitely better). Also looks like I have one thing to fix as well. No promises, but that could also possibly fix the problem on Lion...