Jump to content


Photo

Not possible to switch language on Mountain Lion

Mountain Lion

  • Please log in to reply
5 replies to this topic

#1 Remco Douma

Remco Douma

    Member

  • Members
  • PipPip
  • 14 posts

Posted 30 July 2012 - 09:51 AM

With the sudden passing of Evan, I'm not sure there will be a solution at all, but maybe someone else has run into this problem and found a solution, so here goes.

Since I upgraded to Mountain Lion, I cannot switch languages anymore. I see the languages in the menu, I select another language but when I look again it's set to English still.

Anyone else on Mountain Lion who has a bright idea?

#2 vamp07

vamp07

    Member

  • Members
  • PipPip
  • 15 posts

Posted 31 July 2012 - 04:53 PM

I'm in the same boat..

Steven


With the sudden passing of Evan, I'm not sure there will be a solution at all, but maybe someone else has run into this problem and found a solution, so here goes.

Since I upgraded to Mountain Lion, I cannot switch languages anymore. I see the languages in the menu, I select another language but when I look again it's set to English still.

Anyone else on Mountain Lion who has a bright idea?



#3 pjakobsen

pjakobsen

    Member

  • Members
  • Pip
  • 1 posts

Posted 01 August 2012 - 04:52 AM

I encountered the same problem - but discovered that the language can still changed by changing the default one in the preferences and quitting and restarting the application.

A tad awkward to be sure, but better than nothing.

Let's all hope that Rainmaker Research Inc eventually manages to survive the loss of its illustrious founder - life without his venerable brainchild Thunder/Spell Catcher is very, very hard to imagine.

-pj

#4 Remco Douma

Remco Douma

    Member

  • Members
  • PipPip
  • 14 posts

Posted 01 August 2012 - 07:06 AM

Thanks for the suggestion pjakobsen. This workaround is indeed useful when working on a long document, good tip. Thing is that most of the time I switch between Dutch, Spanish and English every few minutes or so.

I share your hopes.

#5 betalogue

betalogue

    Member

  • Members
  • Pip
  • 1 posts
  • Gender:Male
  • Location:Canada

Posted 01 August 2012 - 03:30 PM

I encountered the same problem - but discovered that the language can still changed by changing the default one in the preferences and quitting and restarting the application.

A tad awkward to be sure, but better than nothing.


You don't need to quit the application. You just need to close the document window and reopen it. This will cause SCX to switch to the (new) default language for the application. A bit faster than having to quit and relaunch. Still a pain, of course.

I tried to find a way to switch languages with AppleScript, but it does not look like SCX's dictionary supports this. (GUI scripting would probably cause the same failure.)

I also found this old thread where Evan discussed this particular aspect:

http://www.rainmaker...t-set-language/

If anyone has more suggestions, they'd be more than welcome. I am trying to decide whether to upgrade to ML now or not.

#6 vamp07

vamp07

    Member

  • Members
  • PipPip
  • 15 posts

Posted 28 August 2012 - 07:19 AM

I switch languages all the time too between Spanish and English. This is a good workaround. Hopefully they can find somebody to take over development. In it current form SpellCatcher is almost perfect for my needs. I just need it updated as necessary to keep up with os changes.