Jump to content


Photo

Dang Language Choice Dialog... Again


  • Please log in to reply
5 replies to this topic

#1 mlcsmith

mlcsmith

    Member

  • Members
  • Pip
  • 5 posts

Posted 31 March 2004 - 11:42 AM

Hello friends,

I suffered a hard XP crash yesterday and when I rebooted Spell Catcher popped up the Language Choice dialog.. except no languages were listed in the dialog/drop-down... thus the OK button was inactive... thus I have no main dictionaries.

Since this happened to me last year, I tired to remember what I did to fix it, to no avail. Anyway, I went ahead and bought 251 and I totally scrubbed Spell Catcher off my system, including removing all registry keys. I also removed any Spell Catcher dlls that were in the driver cache.

I installed 251 and as soon as it ran I got that damned Lang dialog again. *sigh*

Has anyone else reported this problem? Last year when I emailed John, he's never heard of this problem.

Could I hex edit the SC preferences file to set the lang?

Well, I'll keep futzing with it...

-m

#2 mlcsmith

mlcsmith

    Member

  • Members
  • Pip
  • 5 posts

Posted 31 March 2004 - 01:16 PM

Plot Thickening

1) Uninstall SC
2) Create new user
3) Log off
4) Login new user
5) Install SC
6) *SC Runs without error*
7) Quit SC
8) Copy Settings.4SC from new user to my regular user account
9) Log off
10) Log in regular user account
11) *SC complains about language*
12) Copy Settings.4SC from reg acct to new user
13) Log off and into new user acct
14) *SC complains about language - BUT - you can enable main dicts in settings and everything's fine.
15) Compage both Settings.4SC files: bad one is 40 bytes smaller.
16) Head explodes

So... for some reason, only on my regular user account under XP, SC runs and somehow mucks up the Settings.4SC file... hmmm.... test....

1) Set (good) Settings.4SC to read only
2) SC still complains

phooey!

I'll keep fidling...

#3 mlcsmith

mlcsmith

    Member

  • Members
  • Pip
  • 5 posts

Posted 31 March 2004 - 01:45 PM

Problem Solved

1) Log off regular account
2) Login new accout
3) Delete C:\Documents and Settings\regacctname\ntuser.ini

what the hell is that file for anyway?

4) Logout/in
5) *SC runs!*
6) Head unexplodes.

whew!

On second thought, head may explode again, because the contents of ntuser.ini doesn't look like it would have anything to do with SC:

[ G e n e r a l ] E x c l u s i o n L i s t = L o c a l S e t t i n g s ; T e m p o r a r y I n t e r n e t F i l e s ; H i s t o r y ; T e m p ; L o c a l S e t t i n g s \ A p p l i c a t i o n D a t a \ M i c r o s o f t \ O u t l o o k ;

That's about all that's in that file and I swear I didn't touch anything else. I dun no...

Ohhh, look at that cool pop-up suggestion thingy!

OK, how do I make an on-the-fly shorthand spelling correction using the pop-up interface?

Nice to have SC back!

Ta!

-m

#4 John Tytler

John Tytler

    Member

  • Admin
  • PipPipPip
  • 191 posts

Posted 31 March 2004 - 04:55 PM

Hi Matthew,

Sounds like you've had quite a day... thank you for the running dialog on your Spell Catcher installation issues and for figuring your own way out. I'm still at a loss as to what the "C:\Documents and Settings\regacctname\ntuser.ini" file has to do with Spell Catcher's operation or how you managed to figure out that this file was causing some sort of problem.

A new version is coming out in a few weeks, you can be sure that I'll revisit the Language Choice dialog before then. I would like to figure out why it is coming up with no languages.

I've also added a direct route to the shorthand dialog from the popup suggestion menu... nice idea.

Thanks,
John Tytler - Author,
Spell Catcher for Windows

#5 mlcsmith

mlcsmith

    Member

  • Members
  • Pip
  • 5 posts

Posted 31 March 2004 - 07:18 PM

J-man:

1) I was able to figure out the ntuser.ini was causing problems because once I eliminated the registry as being the source of problems and the settings file was getting trashed after it threw up the lang dialog, I knew that it had to be something that was different between the two accounts. That ini file was the first thing I noticed. After rebooting a few times the file has come back, but all it contains is "". Go figure.

2) Since I have your attention... please add an option to select from the pop-up only if you use the keypad enter key... I keep accidentally selecting suggestion number 1 whenever I misspell a word at the end of a Paraguayan.

See?

3) Be sure to add an even more direct route with shorthands that bypasses the add glossary entry dialog completely.

4) I now have 3064 word pairs in my auto-spelling correcting shorthand glossary. Is there a utility that lets me export the list and then re-import it? I want to do some major cleanup. After I'm done I'll turn it over to you guys... any user who spells as badly as me would probably like to have it.

As always, I am eternally grateful to you and Evan for saving my illiterate ass.

-m

#6 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 31 March 2004 - 08:54 PM

1) I was able to figure out the ntuser.ini was causing problems because once I eliminated the registry as being the source of problems and the settings file was getting trashed after it threw up the lang dialog, I knew that it had to be something that was different between the two accounts. That ini file was the first thing I noticed. After rebooting a few times the file has come back, but all it contains is "". Go figure.

Wow, sounds like you had a fun day!

I wonder what's worse - this kind of thing on Windows or Extension conflicts and corrupt preference files on the Mac?

A friend of mine's motto comes to mind:

"When you need it to work the most, technology WILL let you down."