Jump to content


Photo

Spell checking in French


  • Please log in to reply
26 replies to this topic

#1 Poupic

Poupic

    Member

  • Members
  • PipPip
  • 27 posts

Posted 09 July 2004 - 03:47 PM

I write with the system set to English otherwise if in French the keyboard is different. Then I switch to French I make Spell checker check the chosen text. It non-longer works! At odd times it works but when I need it the most it doesn't! I purchase Spell Checker for the express usage as a French spell checker. It used to work perfectly long ago when I use 9 and 8. Please help!

#2 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 09 July 2004 - 07:13 PM

I write with the system set to English otherwise if in French the keyboard is different. Then I switch to French I make Spell checker check the chosen text. It non-longer works! At odd times it works but when I need it the most it doesn't! I purchase Spell Checker for the express usage as a French spell checker. It used to work perfectly long ago when I use 9 and 8. Please help!

Hi again,

We've been through this before. It was an application-specific language default override.

Please review our 20+ emails from last time. I would guess it's exactly the same problem all over again.

#3 Poupic

Poupic

    Member

  • Members
  • PipPip
  • 27 posts

Posted 14 July 2004 - 04:54 PM

We never, ever had 20 exchanges. Nasty answers will not get you any points. Telling me how I can overcome the difficulties of Spell Catcher would. I used this software for years with no problem in exactly the same fashion. Selecting text and Spell catcher worked exceedingly well. Somehow you made a change that affect this software. Do you mind telling us how to make it work again?

#4 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 14 July 2004 - 07:58 PM

We never, ever had 20 exchanges. Nasty answers will not get you any points. Telling me how I can overcome the difficulties of Spell Catcher would. I used this software for years with no problem in exactly the same fashion. Selecting text and Spell catcher worked exceedingly well. Somehow you made a change that affect this software. Do you mind telling us how to make it work again?

This is what you did last time:

Opened the Preferences window, clicked the Applications icon. In the drawer, you deleted (I think) pretty much all of the customized settings. That's not strictly necessary, just delete the one(s) for the application(s) that are causing the problem.

I can look up the old email(s) if you'd like, but that was basically the last one and was the solution for the problem at the time.

#5 paulc

paulc

    Advanced Member

  • Co-Moderator
  • PipPipPip
  • 124 posts
  • Location:New York

Posted 15 July 2004 - 09:20 AM

FWIW, I run an English system and occasionally I need to spell check some French that I have written. I simply set the SCX "checkmark" menu item "Set Language" to French, check the words and then set it back to English. Seems to work consistently.

FYI, I never felt any need to set individual application preferences, so I only use the "Universal" setting.

#6 Poupic

Poupic

    Member

  • Members
  • PipPip
  • 27 posts

Posted 19 July 2004 - 08:30 PM

I have chosen French; restarted, deleted all applications and left universal then I added Tex-Edit again and in no case did Spell Catcher remain in French while trying to check selection. It always returns to US English. This did not happen in the previous version. My version is 10.1.3 with X version 10.3.4.

#7 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 19 July 2004 - 08:58 PM

I have chosen French; restarted, deleted all applications and left universal then I added Tex-Edit again and in no case did Spell Catcher remain in French while trying to check selection. It always returns to US English. This did not happen in the previous version. My version is 10.1.3 with X version 10.3.4.

What are your Language (Spell Catcher Preferences, Langauge pane) preference set to?

What languages are in your list in System Preferences/International/Languages pane, and what order are they in?

Do you have the preference to determine the best language for each paragraph on or off in Spell Catcher Preferences, Spelling, Check Selection?

This absoluetely works, it worked for you for a long, long time. Nothing has changed in this part of the program in Spell Catcher X 10.1.3.

#8 Poupic

Poupic

    Member

  • Members
  • PipPip
  • 27 posts

Posted 19 July 2004 - 11:20 PM

I have made it work by selecting French in the International preference and restarting. Then when checking a selection French is the checking dictionary.

It means that I will have to restart every time I want spell check French text.

#9 Poupic

Poupic

    Member

  • Members
  • PipPip
  • 27 posts

Posted 19 July 2004 - 11:48 PM

Something is really wrong! In system preference International English is on top. Restarting it is now French in Spell catcher! Changing to American flag doesnít change Spell catcherís behavior. In the preference of Spell Catcher US ENglish is selected yet it is still French showing up when checking selected text!!! Restarting after deselecting French in system X preference still gives French only in Spell Catcher. But you think it is me, right?

#10 Poupic

Poupic

    Member

  • Members
  • PipPip
  • 27 posts

Posted 20 July 2004 - 03:43 PM

It is truly amazing! I totally deselected French in preference and in input preference. The French flag is non-longer appearearing ( a great relief!). In Spell Catcher preference the default language is US English. Guess what! Checking a selection it still is French! This after restarting a couple of times!!! There is a bug in Spell Catcher that needs to be fixed. I am a user for many years and love this software. Please make it work again.

#11 Poupic

Poupic

    Member

  • Members
  • PipPip
  • 27 posts

Posted 20 July 2004 - 04:02 PM

You probably will not believe this! In Spell Catcher preferences US English is selected and French deselected. I can spell check French text as if only French was in all the preferences which it is not. English text can non-longer be spell checked because the only choice available is French!!

We have been invaded?? No one knew about it?

#12 Poupic

Poupic

    Member

  • Members
  • PipPip
  • 27 posts

Posted 20 July 2004 - 04:19 PM

Maybe this will help you find the trouble. I select a text. Then I choose to check the selected text from the top of the screen. Spell Catcher in the dock at this instant changes the little flag from the US flag to the French flag when using Tex-Edit. I have just tried the same in Safari. The American flag remains and the text selected is checked in US English. It doesnít matter if Tex-Edit is an application Spell Checker preferences is chosen or not. Even when only Universal is the only choice beside the finder it is always the same thing.

#13 Poupic

Poupic

    Member

  • Members
  • PipPip
  • 27 posts

Posted 20 July 2004 - 05:00 PM

I have just now rebuild my directory with the help of Disk Warrior. I can now again spell check English text again but not French, even when French is the first language in international preference and their flag shows up with spell catcher in the dock but not on top of the screen.

#14 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 20 July 2004 - 07:37 PM

I have just now rebuild my directory with the help of Disk Warrior. I can now again spell check English text again but not French, even when French is the first language in international preference and their flag shows up with spell catcher in the dock but not on top of the screen.

I'm still not convinced there is any sort of problem.

I think you might be getting a couple of things confused, but I'm not positive until you answer some more questions and understand some facts:

Question: What are you referring to when you talk about the "flag at the top of the screen"? Do you mean the title of the input menu (i.e. the current keyboard layout)? If so, please remember that the keyboard layout has nothing whatsoever to do with the current spelling language - it is solely an indication of what physical keyboard is attached to your computer, or at least what keyboard layout you want to be associated with your physical keyboard hardware.

FACT: If you want to check spelling in French in Tex-Edit ALL the time, you should add Tex-Edit to the list of applications in Spell Catcher's Preferences window, then select it and choose to specifically use French (in the Language pane of Spell Catcher preferences) for Tex-Edit. If not, you must first choose French from the Set Language submenu (input/checkmark menu) THEN choose Check Selection from the input menu.

FACT: If you choose Check Selection from either the Services/Spell Catcher menu or Spell Catcher's Dock menu, the language that is used is the one defined in Spell Catcher Preferences/Language pane. ONLY when you choose Check Selection from the checkmark menu will the language chosen in the Set Language submenu be used.

FACT: Choosing a language from the Set Language submenu is a TEMPORARY thing. It does not alter the default language used, just the one used for the current document.

This is all explained in detail in this FAQ. I think you need to read this to understand what you need to do and how things are designed to work.

Remember you can ALWAYS force Check Selection to use a specific language after the initial check is done by choosing that language from the popup menu below the suggestions list, then option-clicking the Check All button. Hover the mouse over the Check All and Check Paragraphs button for more information.

#15 Poupic

Poupic

    Member

  • Members
  • PipPip
  • 27 posts

Posted 21 July 2004 - 07:55 PM

I'm still not convinced there is any sort of problem.

Glad to see that! So why is Spell Catcher no performing as intended on my iMac?

I think you might be getting a couple of things confused, but I'm not positive until you answer some more questions and understand some facts:

Question: What are you referring to when you talk about the "flag at the top of the screen"? Do you mean the title of the input menu (i.e. the current keyboard layout)? If so, please remember that the keyboard layout has nothing whatsoever to do with the current spelling language - it is solely an indication of what physical keyboard is attached to your computer, or at least what keyboard layout you want to be associated with your physical keyboard hardware.



FACT: If you want to check spelling in French in Tex-Edit ALL the time, you should add Tex-Edit to the list of applications in Spell Catcher's Preferences window, then select it and choose to specifically use French (in the Language pane of Spell Catcher preferences) for Tex-Edit. If not, you must first choose French from the Set Language submenu (input/checkmark menu) THEN choose Check Selection from the input menu.

I deleted Tex-Edit from the applications and tried to add it again. It always disappears when starting Spell Catcherís next spell checking.

Do you mean I have to check the language from what is commonly called a pull down menu? If so, I do that but then when I choose the text to be checked in French it reverts back to English.

FACT: If you choose Check Selection from either the Services/Spell Catcher menu or Spell Catcher's Dock menu, the language that is used is the one defined in Spell Catcher Preferences/Language pane. ONLY when you choose Check Selection from the checkmark menu will the language chosen in the Set Language submenu be used.

I have just gone into the Spell Catcher preference and unchecked English but checked French. From the pull down menu I chose check selection (Text highlighted in French and active) It shows in the choice of language US English. I change it to French and it reverts back to US English.

FACT: Choosing a language from the Set Language submenu is a TEMPORARY thing. It does not alter the default language used, just the one used for the current document.

This is all explained in detail in this FAQ. I think you need to read this to understand what you need to do and how things are designed to work.

Remember you can ALWAYS force Check Selection to use a specific language after the initial check is done by choosing that language from the popup menu below the suggestions list, then option-clicking the Check All button. Hover the mouse over the Check All and Check Paragraphs button for more information.

No you canít! It doesnít work that way at all! Iíve tried it to no avail. It used to work and now it doesnít.

#16 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 21 July 2004 - 08:47 PM

Glad to see that! So why is Spell Catcher no performing as intended on my iMac?

Because of a preference set incorrectly - I am absolutely convinced. It is not a bug in the program - witness the fact that you said it used to work, then you changed settings, and it's not working the way you want now.

I deleted Tex-Edit from the applications and tried to add it again. It always disappears when starting Spell Catcherís next spell checking.


Yes, it will disappear from the list if you don't actually make any changes to the settings (preferences) that are different from the Universal ones.

Do this:

Add Tex-Edit again.
Click on the Language icon to reveal the language pane.
MAKE SURE that Tex-Edit is selected in the Applications list (drawer).
NOW choose French as the default spelling language for Tex-Edit.

I guarantee that will work.
Provided you do as stated above.

NOTE that you will likely have to quit Tex-Edit and re-open it for this to take effect (no need to quit Spell Catcher).

I have just gone into the Spell Catcher preference and unchecked English but checked French.  From the pull down menu I chose check selection (Text highlighted in French and active) It shows in the choice of language US English. I change it to French and it reverts back to US English.

I'm not sure what you mean by this. Sounds like a bad idea.

Also realize that just because YOU know that a selection of text is in French does not mean that Spell Catcher can know this!

Remember you can ALWAYS force Check Selection to use a specific language after the initial check is done by choosing that language from the popup menu below the suggestions list, then option-clicking the Check All button. Hover the mouse over the Check All and Check Paragraphs button for more information.

No you canít! It doesnít work that way at all! Iíve tried it to no avail. It used to work and now it doesnít.


Yes it does. Try it again.

But you shouldn't have to if you have set French as the default language for Tex-Edit as described above.

#17 Poupic

Poupic

    Member

  • Members
  • PipPip
  • 27 posts

Posted 22 July 2004 - 07:51 AM

I am not sure what you mean by select French in Tex-Edit preference. There is no place in Tex-Edit to choose French. In Spell Catcher preference while highlighting Tex-Edit I selected French to the right of it. Selecting text I get the same result U.S. English not French and of course Tex-Edit is gone from the preference once I leave it.

Do yoou have a concise manual available?

#18 tbailey

tbailey

    Member

  • Members
  • PipPipPip
  • 118 posts

Posted 22 July 2004 - 11:12 AM

Oh my gosh! I've been reading this thread for days, and honestly, I don't know how Evan can keep responding with such calmness. Obviously, he doesn't want to offend this user, but honestly, it must be tempting to do it just this once! "Poupic" might get mad and not buy SCX again, but wouldn't it be worth the few $$?

Poupic: Evan has given you step-by-step instructions what to do, but you know SO LITTLE about the program that you can't even follow them! This becomes sooooo obvious when you ask if there is a "concise manual" available. How can you have read the manual, when you don't even know if there is one!

Evan, no one would blame you if you drew the line here and said until he reads the manual, you will not continue this (20+ again) thread. In fact, we all know you have better things to do with your time, like working on the next update of SCX! Do us all a favor, and use your limited resources toward something more profitable.

Tom

#19 Poupic

Poupic

    Member

  • Members
  • PipPip
  • 27 posts

Posted 22 July 2004 - 11:34 AM

Open the manual and show me where there is a concise explanation how to Spell Check. I will be forever thanking you. Good luck!

#20 Poupic

Poupic

    Member

  • Members
  • PipPip
  • 27 posts

Posted 22 July 2004 - 04:28 PM

I ment to say spell check in French. Show me where in the manual this is stated clearly and that I did not try. Go ahead! I use this software for many, many years. As of late there is problems using it in system X. There is a problem instead of attacking the messenger without proposing a solution is real smart. Speaking of paying for the sotware did you pay for it? II paid for it a few times over the years. I have not complained about the cost. It is well worth every penny while using Spell Checker in English. No question about that! I use it to spell check also and very rarely in French. When Spell Checker works in French it is definitely worth every penny even if I used it only in that language.

There is a problem that neither I nor the programer has solved yet. I will be enormously happy when it is. I know it will work again in French since it did very well previously.

Having said that, big mouth go and purchase the software instead of lurking and muddying the water.