Jump to content


Photo

Spell checking in French


  • Please log in to reply
26 replies to this topic

#21 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 22 July 2004 - 06:47 PM

Everybody calm down...

You didn't follow my advice.

Open Spell Catcher Preferences. Click the Applications icon to open the drawer with the list of applications. Add Tex-Edit to the list. Make sure Tex-Edit is selected. Click the Language icon to veiw Spell Catcher's language preferences.

Change the language to French in the popup menu.

This sets it to French by default in Tex-Edit, and English (presumably) everywhere else.

Got it now?

I know you had this working before, I can forward the emails you sent to me when you finally figured it out to you if you'd like.

And please, right now, without delaying - click this link to read our FAQ that explains all this thoroughly, better than the manual does.

And if you need help, just choose Spell Catcher Help from the Help menu in the Spell Catcher application. It is more up-to-date than the manual.

#22 Poupic

Poupic

    Member

  • Members
  • PipPip
  • 27 posts

Posted 22 July 2004 - 07:58 PM

Everybody calm down...

You didn't follow my advice.

Open Spell Catcher Preferences. Click the Applications icon to open the drawer with the list of applications. Add Tex-Edit to the list. Make sure Tex-Edit is selected. Click the Language icon to veiw Spell Catcher's language preferences.

I did many times and every time it goes away. I used to have Tex-Edit in the list of applications.

Change the language to French in the popup menu.

Do you mean in the pull down menu Under selections? If so, I change it and it always reverts back to US English.

This sets it to French by default in Tex-Edit, and English (presumably) everywhere else.

Got it now?

I know you had this working before, I can forward the emails you sent to me when you finally figured it out to you if you'd like.

And please, right now, without delaying - click this link to read our FAQ that explains all this thoroughly, better than the manual does.

And if you need help, just choose Spell Catcher Help from the Help menu in the Spell Catcher application. It is more up-to-date than the manual.
OK

#23 Poupic

Poupic

    Member

  • Members
  • PipPip
  • 27 posts

Posted 22 July 2004 - 08:18 PM

1)Moved French on top of International in preferences

2) Restarted

3) Tex-Edit added in Applications

4) French selected in Languages

5) After selecting text to spell check French selected in pull down menu

6) Spell Catcher still looks at the selected text as English while French flag is in the dock.

#24 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 23 July 2004 - 02:33 AM

1)Moved French on top of International in preferences

2) Restarted

Not strictly necessary. This changes your scenario, however, since I know you normally have English as the first language in the list.

3) Tex-Edit added in Applications

4) French selected in Languages

5) After selecting text to spell check French selected in pull down menu

6) Spell Catcher still looks at the selected text as English while French flag is in the dock.


I cannot reproduce this. It works perfectly.

There is only one way I can think of where the default language you set for Tex-Edit may not be used, and that is if you use the Check Spelling command(s) in the Edit->Spelling submenu (due to the incomplete support for Carbon apps that want to use the OS X Spelling Panel).

I still do not understand the statement "Spell Catcher still looks at the selected text as English". What is the language displayed in the popup menu below the list of spelling suggestions?

Are we even talking about the same function here, "Check Selection"? How are you invoking the Check Selection command? Via the Services->Spell Catcher menu? Via the Dock menu? Via the Check Selection or Check All command in the input (checkmark) menu?

This works, I am still quite convinced you have a preference or other similar settings problem.

#25 tbailey

tbailey

    Member

  • Members
  • PipPipPip
  • 118 posts

Posted 23 July 2004 - 10:50 AM

Everybody calm down...

I'm calm. In fact, I'm smiling. This is quite amusing to me. I wonder how long you will keep trying to help, Evan. You are too good natured.

Speaking of paying for the sotware did you pay for it?


Ahh, yaa. Duh. Not a very intelligent question.

Having said that, big mouth go and purchase the software instead of lurking and muddying the water.


Another intelligent-showing statement. I don't read these posts because I haven't purchased the software, I read them BECAUSE I have. Along with reading the manual (and FAQ) I pick up on things that I then don't have to consume the Programer's time with. You should try it some time.

Don't be such an imbecile! (look up it's meaning in SCX, it's of French origin!)

Tom

#26 Poupic

Poupic

    Member

  • Members
  • PipPip
  • 27 posts

Posted 23 July 2004 - 11:24 AM

Tom, you are well named for a turkey!

Here is the more important part:

Spell Catcher is great! It has been years I enjoy using it and would not be without it.

PROBLEM SOLVED! This is how I solved it:

1) For the first time French again remains in applications after leaving preference and spell checks French perfectly again

2) Changing back to English in preference & checking English text : French spelling is on, not English

3)Problem solved ! Quitting Tex-Edit and restarting checking English text works again.

4) Changing back from English to French in languages : English is on and in Preference Tex-Edit is gone !

5) Quitting Tex-Edit and restarting it French is on in Spell Checker

6) Looks like there is no need to have Tex-Edit in applications since it goes away anyway. Universal is enough and sufficient.

Going from language to language the application used must be restarted otherwise the language previously used remains active.

Thank yo for a wonder program I can’t live without. This why I was so intent to have it work again for me. Thank you for your time.

#27 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 23 July 2004 - 07:21 PM

Tom, you are well named for a turkey!

Here is the more important part:

Spell Catcher is great! It has been years I enjoy using it and would not be without it.

PROBLEM SOLVED! This is how I solved it:

1) For the first time French again remains in applications after leaving preference and spell checks French perfectly again

2) Changing back to English in preference & checking English text : French spelling is on, not English

3)Problem solved ! Quitting Tex-Edit and restarting  checking  English text works again.

4) Changing back from English to French in languages : English is on and in Preference Tex-Edit is gone !

5) Quitting Tex-Edit and restarting it French is on in Spell Checker

6) Looks like there is no need to have Tex-Edit in applications since it goes away anyway. Universal is enough and sufficient.

Going from language to language the application used must be restarted otherwise the language previously used remains active.

Thank yo for a wonder program I can’t live without. This why I was so intent to have it work again for me. Thank you for your time.

Going from language to language the application used must be restarted otherwise the language previously used remains active.


Yes, true statement - that is if you change the default spelling language AND Spell Catcher is the active input method (not an issue if you haven't chosen Spell Catcher from the input menu) you will likely have to quit and re-launch the app you are in.

This is because the language chosen via "Set Language" is persistent for the particular document window that is open at the time (at the very least).

This is explained in the FAQ I directed you to.