Jump to content


Photo

Spell Catcher is still curious about learned words


  • Please log in to reply
6 replies to this topic

#1 Cervus

Cervus

    Member

  • Members
  • Pip
  • 4 posts

Posted 20 January 2005 - 02:35 AM

After I type a new word and tell Spell Catcher Plus to learn it, the program still recognizes this word as a "curious" thing, although the word is in the "My Learned Words" dictionary. Where did I go wrong?

By the way, it is very uncomfortable that Spell Catcher Plus suggests substitutions even when I enter my passwords... I hoped that, at least, I would be able to fix this by adding my passwords to learned words (not the best solution though), but as I said above it does not help.

Can anyone help me?

#2 John Tytler

John Tytler

    Member

  • Admin
  • PipPipPip
  • 191 posts

Posted 21 January 2005 - 11:55 AM

After I type a new word and tell Spell Catcher Plus to learn it, the program still recognizes this word as a "curious" thing, although the word is in the "My Learned Words" dictionary. Where did I go wrong?

By the way, it is very uncomfortable that Spell Catcher Plus suggests substitutions even when I enter my passwords... I hoped that, at least, I would be able to fix this by adding my passwords to learned words (not the best solution though), but as I said above it does not help.

Can anyone help me?

<{POST_SNAPBACK}>


Hi,

If anyone can help, I can... :-)

On dealing with the issue of words not being learned -> that is strange since Spell Catcher is makes every effort to store words in references that are currently loaded.

Try using Find in References... after adding a word to see if that learned word is located in the reference you just stored it in. Find in References... only searches references that are currently loaded for the language that you are currently using (you may have installed multiple language references). If this isn't able to find your newly added word then that word was put in a reference that isn't loaded or pertains to another language (more likely the first case).

You can see if that reference is loaded by going to the Settings->Reference Files panels. There, you should see a yellow checkmark to the left of the reference's name.

Get back to me here on your findings...

With respect to passwords, I've developed the habit of entering the password and then either clicking on the login button or using SHIFT + TAB to tab to it.

Holding down the SHIFT key while tabbing or spacing after a word causes Spell Catcher to ignore the word you've just typed - so there is no need to put your passwords into any learned words file.

You can try this out and let me know what you think...

Thanks for the posting,
John Tytler,
Author - Spell Catcher Plus
Rainmaker Research, Inc.

#3 Cervus

Cervus

    Member

  • Members
  • Pip
  • 4 posts

Posted 21 January 2005 - 12:07 PM

Dear John,

Thank you a lot for your response.

When Spell Catcher Plus detects a word it doesn't know, I click on the Learn button, so the word is added to My Learn Words (I made sure it is). Nonetheless, when the program meets this word again, it sill suggests possible substitutions. This is very inconvenient when you type your password, as anyone looking at your monitor can quess it when Spell Catcher Plus shows that yellow list.

I use only English language, so I don't think any of your suggestions is right. However, I hope that you can help me with this issue.

By the way, is there Russian dictionary available? I would be happy to get it.

Thank you again for your help.

Michael

#4 John Tytler

John Tytler

    Member

  • Admin
  • PipPipPip
  • 191 posts

Posted 21 January 2005 - 03:04 PM

Hi Michael,

Try using Find in Reference Files... (it's an item in Spell Catcher's menu) to ensure that the word has been added to a file that is currently loaded (being used) by Spell Catcher. I suspect that your Learned Words file is not being used by Spell Catcher.

To fix this open Spell Catcher's Settings dialog, go to the Reference Files panel and make sure there is a yellow checkmark beside your Learned Words file.

Concerning your passwords - try holding down the SHIFT key while pressing either the Tab or Enter key once you have finished typing the password. You could also click the Login button with your mouse once you've entered your password...

If you do either of these things Spell Catcher will not complain about your password.

Sorry, we don't have any Russian reference files.

Let me know how it goes...
Thanks,
John

#5 Cervus

Cervus

    Member

  • Members
  • Pip
  • 4 posts

Posted 25 January 2005 - 03:09 AM

Hello,

I have made a couple of screen shots which show that the password I type had been added to My Learned Words and the My Learned Words dictionary is enabled, yet Spell Catcher Plus is still curious about this word when I type it.

Posted Image
Posted Image

Could you please explain me where I go wrong? Thank you a lot.

Best regards,
Michael

#6 John Tytler

John Tytler

    Member

  • Admin
  • PipPipPip
  • 191 posts

Posted 28 January 2005 - 10:00 AM

Hi Michael,

I'm not sure - that may depend on what characters are in your password.

Try adding the word spiffle to your learned words file to see if that word is not longer detected as an error.

If spiffle is no longer detected as a typo (after you've added it), then there is something that is particular about one of the characters in your password that is causing Spell Catcher to think of it as two words.

Let me know what happens...
John

#7 Cervus

Cervus

    Member

  • Members
  • Pip
  • 4 posts

Posted 07 February 2005 - 03:15 AM

Hello John,

I am sorry, but my demo-version of Spell Checker Plus has expired. The main problem is not the one I described (we may still work it out), but the absence of a Russian dictionary. I think like I will try to search for a spell checker that has one.

Thank you for all your help.

Cheers, Michael.