Jump to content


Photo

making auto-show completions start and stop


  • Please log in to reply
1 reply to this topic

#1 Paul Ingraham

Paul Ingraham

    Member

  • Members
  • PipPip
  • 28 posts

Posted 26 April 2005 - 12:16 AM

SC X's auto-completion feature is really handy sometimes, and distracting and annoying at other times. Therefore, it is important to be able to quickly and easily turn it off... and back on again.

Fortunately, you can!

For the longest time I thought the only way to turn off auto-show completions was in the preferences. But no! SC X has so many features, it often takes me a long time to notice obvious ones. It turns out that the "auto-show completions" item in the input menu is equivalent to checking or unchecking the "automatically show completions after typing [?] characters" in the completion preferences!

Auto-show completions is not assigned a hotkey by default. I use auto-completion much more than I use auto-suggestions, so I simply swapped the hotkeys using the keyboard shortcuts preferences.

I find that this is incredibly efficient when combined with a good keyboard shortcut for the "Complete" command in the Input Menu. Either my completions are already showing automatically, or a list of suggestions for the current word is instantly available with the keyboard shortcut.

#2 Evan Gross

Evan Gross

    Administrator

  • Admin
  • PipPipPip
  • 2,991 posts
  • Gender:Male
  • Location:Toronto, Canada
  • Interests:This Place!

Posted 26 April 2005 - 09:33 PM

Auto-show completions is not assigned a hotkey by default.  I use auto-completion much more than I use auto-suggestions, so I simply swapped the hotkeys using the keyboard shortcuts preferences.

<{POST_SNAPBACK}>


Actually, there is a keyboard shortcut assigned by default, but if you've upgraded from a prior version that didn't have completion, you won't see it unless you select it in the Shortcuts preference pane and click "Item Default".