Spell Catcher FAQs & Knowledge Base

Main > Spell Catcher X > Spell Catcher X 10.4  
Spell Catcher X 10.4

I use MobileMe Sync with Spell Catcher X 10.4. Should I migrate my MobileMe account to iCloud when it's available?
No, Not Yet! MobileMe will remain available until June 2012. All 3rd party applications that support MobileMe Syncing must be updated to support any equivalent iCloud f
- 2011-10-13 - Similar Articles

Is Spell Catcher X compatible with Mac OS X 10.7 (Lion)?
(Updated Tuesday, 13 December, 2011.) Spell Catcher X 10.4 - Yes Spell Catcher X 10.4 has been undergoing testing and development with Lion developer builds f
- 2011-12-19 - Similar Articles

How do I downgrade from Spell Catcher X version 10.4 to 10.3.7?
If you decide not to purchase the upgrade to Spell Catcher X 10.4 after installing it and taking it for a test drive, you can downgrade to version 10.3.7 by following these st
- 2011-06-17 - Similar Articles

Updating language plug-ins
New for Spell Catcher X 10.4 Some features have been added to the Get Updates and Languages window for Spell Catcher X 10.4. We’re planning on more improvements,
- 2011-06-06 - Similar Articles

Powered by KnowledgeBuilder